Jump to content
Sign in to follow this  
Megee

My layouts went crazy!!!

Recommended Posts

a user decided to copy a record and change a few things instead of creating a new record and retyping the info. now my "last name" field doesnt change with the records, and on other layouts calculated fields are showing #s where its supposed to be a calculation of first and last names. plus, on other layouts fields from the main db dont change with their related record...they all show the same data in the field, but if you check the original records they are mostly different. pretty much all hell broke lose with the copying of a record was selected....what should i do, other than shoot the user....i dont see what changed. please, give me any sort of advice!!!!

thanx

travis

Share this post


Link to post
Share on other sites

... change a few things

Most certainly. They got into layout mode, it sounds like. Simply duplicating a record wouldn't cause all of this. I believe your data is fine, although every time something is created or changed, it could now be referencing wrong relationships and messing you up further. You had better nail down what they did FAST!! And I wouldn't let anyone use the system until it was fixed. Not good, Travis.

Check first that they changed the table occurence that the layout is based upon. But if several layouts are affected, they did more than simply change a layout or field format. And if text calculations are showing numbers (on more than one layout?) then it sounds like they changed some field definitions - maybe even File References or relationships - who knows.

I'm not sure I would trust that you catch all the things they did. I would consider copying the data into a new copy of your design if you can't figure it out quickly. And then search for the latest modification dates and manually check each one.

And yep. Shoot them. But shoot yourself also. Your solution should have had protections in place. Deny access to Layout Mode and all design features. Most Users just do their job ... an occasional user is nosey and know-it-all and will run wild if given the chance. You need to protect everyone from that ONE user. Every business has one, I'm afraid. I wish you well in solving it.

Share this post


Link to post
Share on other sites

ok, im getting back to where i need to be except for one major thing that i see. my Lname field wont change with each record. it stays the same as the last data entered

to get where i am i exported and imported into an empty copy of my file.

travis

Share this post


Link to post
Share on other sites

Make sure your Lname field on the layout is using the current table and is not a related field.

Share this post


Link to post
Share on other sites

ok, i checked the Lname field and it is using my current table...ive concluded that doesnt matter too much because i can create a new field in place of Lname for another layout that uses Lname. a bigger problem i have is on a layout where im creating a cover. i have a field called CoverName where it caculates something like prof::Title & " " prof::Lname. this field is not showing any data whatsoever. i tried using prof2 in the calculation but that did not bring up any names either. why would the field not even give me a question mark???

Share this post


Link to post
Share on other sites

Honestly, I have no idea without looking at it. Can you zip and attach a sample of your file?

Share this post


Link to post
Share on other sites

ok, so if i do what i said i would do...the problem is fixed. its happening when i import the records.....originally when i had my file "complete" i made a copy of it with all records gone so i would have it in this situation. so i exported the data into three separate files, one for the order, one for our professor database, and one for our department db. so i import these back into the file and thats when the problem occurs. the message i receive claims no records are lost, so i didnt think the problem was there. new records i enter do show up on the layout that im having trouble with.

i dislike computers....why did i choose this path again?

Share this post


Link to post
Share on other sites

If you have any auto-entered fields, your import needs to have the perform auto-enter options selected. Otherwise, they will not be populated. That could be why fields using relationships are not working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  
      Thanks!
      -Tony
      Recover.log

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
  • Who Viewed the Topic

    9 members have viewed this topic:
    Ocean West  xochi  Mike Owen  mmcmanus  rtor451  Jim Gill  Shanzo  Thorsten Kaltenborn  pleiades 
×

Important Information

By using this site, you agree to our Terms of Use.