Jump to content

Copy bug in FM 6 over Win2003 Terminal Server

Eric Kelly

This topic is 6635 days old. Please don't post here. Open a new topic instead.

Recommended Posts

We have FM Server 5.5 running on a G4, accessed by FM 6 clients on OS X 10.3 and XP. We just installed a terminal server running Windows Server 2003. In testing out our rather complex database solution over terminal services, I encountered one print script that is supposed to only select records for the current user and print them. Instead, it prints every user's records. I narrowed down the failure to the following script steps:

Copy [select, "gID Current User"] <-- this is a global field

Enter Find Mode []

Paste [select, No style, "User ID"] <-- this is a number field

What fails (apparently randomly) is that the copy step fails to copy the global field, even though the global field is right there on the layout. This happens about once every 2-10 times the script is executed, and it only happens when using terminal services. Once it has happened, running the above mini-script fails unless I go into browse mode and start over. I have tried inserting pauses into the script, telling it to go into browse mode before copying, turning error capture on and off, and nothing has worked.

Two questions:

Is there any known fix for this?

If not, can anybody think of a workaround? I need to set the number field to the value of the global field while in find mode somehow.


Link to comment
Share on other sites

I have found this bug to be present in Windows 2003 Terminal Server as well - I use a logon script that copies and pastes some values - sometimes when users sign onto the Terminal Server, the "copy" and "Paste" functions simply don't work. But its not just limited to FileMaker (6 or 7) - it doesn't work on thast session at all. the user must log off and then log on again and then (normally) everything goes fine. My only workaround is to try to copy and paste when the user signs in - capture the result and if it is blank - tell the user they have to log off and log on again.

Link to comment
Share on other sites

Good to know the problem is not just unique to our setup.

I *think* I may have found a workaround. Because the problem is intermittant, creating a loop seems to work:


Enter Browse Mode []

Copy [select, "gID Current User"]

Enter Find Mode []

Paste [select, No style, "User ID#"]

Exit Loop If ["IsEmpty(User ID#)=0"]

End Loop

Perform Find [Replace Found Set]

Running this little test script, I can sometimes see the screen blinking repeatedly as it cycles several times, but so far it has always eventually been successful at copying and pasting.

The other thing I haven't tried yet, and need to wait till the weekend, is to update FM Server 5.5 from v2 to v4, though from the fix list it doesn't look like this will change anything relevant to our operation.

One other issue which I'm not sure if it is with our terminal server setup or if it is a FM bug is that we keep dropping the connection, sometimes as often as every minute or two, and other times not at all during a 2+ hour session.

Link to comment
Share on other sites

OK, scratch that previous post. In fact, sometimes the routine never works, so the loop above just goes on endlessly. A much better solution is:

Enter find Mode []

Set Field ["User ID#", "gID Current User"]

Perform Find [Replace Found Set]

In other words, use Set Field instead of copy/paste -- which normally I always do, except I had been laboring under the misconception that setting a field using a global didn't work when in find mode. The problem was that I was trying to set a field from a global that was a different *type* of field. Unfortunately, I still have several scripts where I have to do this, involving date fields. I guess I'll use a loop script like in my previous example, but include a counter that exits after 20 passes and tell the user to try again.

Link to comment
Share on other sites

This topic is 6635 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.