Jump to content

ODBC installed but missing


This topic is 6600 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hello All,

I recently installed the ODBC drivers that were on the Filemaker 7 Pro disk. I go to access them, but they are no were to be found in the ODBC Admin.

What is odd, is that I go in to a different program that I what to map Filemaker to (UPS Worldship) and they are there, but there is a blank line seperating them from the other drivers.

Any ideas??

Link to comment
Share on other sites

All right I found it. You have to delete an extra Default key in the registry.

Now anothere problem.

I'm connecting UPS Worldship to Fielmaker.

It is asimple thing, but the ODBC driver for Filemaker gives me an error messsage saying that this driver is only to be used for Filemaker...


Link to comment
Share on other sites

All right maybe I'm missing something.

I looked at my old 5.5 ODBC drivers and one was called FilemakerPro, not Filemkaer Oracle, Filemaker TXT, Filemaker SQL, just Filemkaer Pro,

Is there a Filemaker Pro ODBC Driver for Filemaker 7.0?::?:?:(??????


Link to comment
Share on other sites

I'm having the same problem as the original post. I installed the DataDirect32bitSequelink5.4 driver, but it doesn't show up on my list of drivers in ODBC administrator.

I deleted an extra default key in the registry, but it's still not showing up. Any suggestions??

Link to comment
Share on other sites

I have two of the three showing, by deleting the Default value, but the driver for the datalink is still missing!!!


I've tried the un-install/re-install too many times to count.. I delete that stupid extra default key and comes back.

MY ? to jcarson is do you have any other programs that list the possible drivers. I do, in Worldship, you can choose files, and it shows all the known drivers, then the is a blank line then the filemaker drivers are under that blank line..

My head is starting to hurt, I keeping butting my head against this wall, but it just will not work!!!

HAs anyone out there ran in to this and figured it out??

I wish more people read this ODBC forum

Link to comment
Share on other sites

I followed the below steps that someone else posted in a different thread, and it shows up now.

"You need to delete an entry out of your registry. Here are the instructions:

DataDirect KnowledgeBase

Successive attempts to install/reinstall the drivers do not resolve the issue.

In the windows registry editor tool ( regedit.exe ), open the registry key


Look for an entry in this key whose name is


The value of this entry should be

(value not set)

When experiencing the problem described above, the value is actually set to an empty string.

To correct the problem, simply right-click on "(Default)", select "Delete" from the drop-down menu and click "Yes" to confirm that you wish to delete this value.

Doing so should restore "(Default)" to its correct value, "(value not set)". After doing this, uninstall and resinstall your ODBC drivers and you should be able to see them in the ODBC Data Source Administrator."

Link to comment
Share on other sites

  • Newbies

As an early adept to FM Pro 7, I studied ODBC functionality for months.

I have contacted FM support, I have contacted DataDirect, I have studied the FM white paper about ODBC SequeLink installation, the knowledge databases of DataDirect, erything. The result was the following:

On a single machine re-installing the driver resulted in the driver to be listed in the ODBC administrator. On all the other machines, I re-installed indefinitely, I deleted the Default key from the registry indefinitely, and nothing helped ??? the driver does not appear in the list.

I finely gave up.

PS ??? as I said the installation worked on a single machine. I then tried to use ODBC for Word mail merge : it does not work. Using it with Excel from the other side was no problem.

(I used ODBC functionality with FM 5.0 and 6.0 for years without problem).

I hope there will finely be somewhone with a solution that really works.

Link to comment
Share on other sites

I want to say thanks for all the help.

jcarson was right it worked. It is like you have to hit the reset button.

I still feel that Filemaker ODBC are a little to complicated, and this bug hopefully will be fixed in future version.

Link to comment
Share on other sites

  • 2 weeks later...

This topic is 6600 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.