Jump to content

Strange Problem accessing related fields


This topic is 6607 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

I'm working on a project using fx.php w/ 7 advanced. Everything works fine when all the fields on the layout are from the table the layout based on. I can also use fx.php to pull value out the layout with related fields. However, when I tried to add or modify the value of the related field, I'll get error code 101, which according to FMP doc means record is missing, even though I can retrive the data for that record in fx.php.

I tried to send command like


in the browser to FMP7 directly, and still getting the same error in xml result. And when I send command like


to add record, I'll get error 504, which according to FMP is Value in field is not unique as required in validation entry options. And nope, the field definition in database does not any any validation or even autoentey. Just simple text field.

I'm having this problem w/ all the databases hosted by this FM7 advanced installation, and everything works fine within FMP 7 clients. The problem might have came up after 10.3.7 server update, but I can't say for sure. BTW, in case it helps, the box is Xserve single G4 processor w/ 512MB RAM, running 10.3.8 and FMP7 advanced 7.02 My project is progressing nicely, until I ran into this problem. If anyone can shed some light on this I would really appreciate it.


Link to comment
Share on other sites

This topic is 6607 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.