Jump to content

PDFs. Filesize and fonts.


macmekker
 Share

This topic is 5681 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi.

I have seen the issue of FM 8 integrating fonts when creating pdfs being mentioned somewhere, but now I can not find any threads dedicated to this... So I was hoping somebody could guide me/give me the highlights...

My story in short:

The font we use for printing i our company: Myriad (all printing/pdf are done with Macs)

I am now upgrading our solution from FM6 to 8. A 24 page list saved as pdf (via "print") in the FM6 solution has a filesize of 530KB. Now - in 8 - it is 8,3 MB !!! So I tried the new "Save as PDF" function, and the new filesize was 250K ! I was very happy for a few seconds. But when I opened the pdf doc - all was empty - or rather: it was still 24 pages, correct formatted with logo, lines and text presented with other fonts. But all text in Myriad was gone/empty.

SO is this function actually reduced to documents using a few selected fonts?

Edited by Guest
Link to comment
Share on other sites

Had this problem too . . .

In reading what's updated in v8.02, here's something :

1.5. On Mac OS X, fonts that have Postscript outlines instead of TrueType outlines no longer appear as out of range squares or invisible when saved to a PDF file.

For the whole list, see :

http://www.filemaker.com/support/updaters/fm8v2_mac.html

Link to comment
Share on other sites

I am having the same problem. See Post 185765 in this list. The 8.02 update has made a difference. Using Send/Save as pdf produces a pdf that looks ok but has no font information. Not useful for printing.

Outputting as postscript then distilling produces a pdf that seems ok. When you open the pdf and select pdf optomizer from the advanced window the fonts show and you have the option to embed them. I have not fully tested but the upgrade seemed to have made some improvements.

Link to comment
Share on other sites

  • 4 weeks later...

It would also seem that you need to have the actual font installed on the computer to view the pdf's fonts . . .

Saving the page as PDF 'should' save the enough font information (in a format that anyone who has Acrobat Reader can open) in the file.

The 8.0v2 update only seems to have fixed 'half' the problem . . .

mav.

PS: I do have Acrobat 'Full' installed on the mac, which means I can use the built-in 'Adobe PDF' printer driver to build PDFs, but this method does not allow for PDFs to be named, built, saved to a directory, and an email created with the file as an attachment in one script

Link to comment
Share on other sites

  • 1 month later...

I posted this in another thread but hope this helps:

I have the same problem but I think I found out why.

After printing to .pdf in OS X I looked at the 3 page .pdf that contained NO graphics and saw that it was 2.3 megs!

So I opened it up in Acrobat 7 Pro and tried to do an Optimize PDF command on it...tried and failed because it got hung up on the 'replacing duplicate fonts' process.

After force quitting and restarting Acrobat I opened it again and looked at the font situation. WOW!

In FMP I had only used helvetica and the only text style add I did was a bold; however, Acrobat said there were about 60 versions of helvetica in the .pdf. I manually deleted all but 1 each (regular and bold) and save again. That made the .pdf 232k.

So, if you have ACP7 it can be fixed. I have a guess that maybe everytime you have a different size or style of text, FMP is embedding a whole nother copy of the font so maybe convert every font to the same style and size to test whether the file is smaller.

Link to comment
Share on other sites

This topic is 5681 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.