Jump to content

Activate Security settings will not work


Rob Tito
 Share

This topic is 5708 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Standard I include or activate accounts and security levels just before I either publish a database or run the final end users tests.

Now I have a 50 GB database in FMP 8 and I tried to activate the already present accounts. (I used standard login using account/password.)

After disabling the standard login nothing changes, as if the security isnt really active.

When I create a clone of the database it all seems to work fine.

It got me by surprise as I didnt expect this behavior.

Any advice how to get this (*&(I*& security and accounts active without having to rebuild starting from the clone?

The 7 million records will take more then a month to be imported into FMP clone. Seems like a terrible waste of time.

TIA

Rob

Link to comment
Share on other sites

Welcome Rob,

After disabling the standard login nothing changes, as if the security isnt really active.

Can you be a little more specific about what's actually working or not working. I don't know what "standard login" or "nothing changes" is really saying.

Also, how many files and how many accounts are we talking about here?

Link to comment
Share on other sites

Sorry if that was not clear: standard log in is with an account preset, e.g. Admin/password.

Disabling that should enfource you to use an account name and the appropriate password. That now is not working in the database, yet is works immediately when I save the database as a clone (and fill it with some data)

Hope this clearifies my question.

Regards,

Rob

Link to comment
Share on other sites

Not much.

Do you mean you're disabling the automatic login option in File Options, and it's then not giving a Login dialog when the file is opened?

Perhaps you have an OS X keychain set for it. Check Applications/Utilities/Keychain Access.

Edited by Guest
Link to comment
Share on other sites

That is what is happening. But the password differs from the standard keychain password. And since it does work accordingly, starting up with an login window when I create a clone from the same database, it doesnt make much sense to me. I merely want to have any user being forced to login using their account and password and hence their permissions on the file.

Link to comment
Share on other sites

The keychain remembers the password for that particular file on that computer. If you move the file to another machine, the user should be presented with a Login dialog (which they may or may not set their own keychain on.) If you wish to get the login dialog back on your computer, delete the keychain entry for that file.

Link to comment
Share on other sites

No problem, Rob.

This feature of keychains is meant to be a useful thing, and I'm sure in environments where everybody has their own computer, it is. In my environment, I have many users that share computers, so this "feature" is a big security risk. And yes, it's a pain to work around.

But it's useful to know about it (and know how to deal with it,) even if everyone has their own computer, as eventually employee turnover will result in a situation where the new employee gets logged into the old employee's account unexpectedly. :shocked:

Link to comment
Share on other sites

thanks for the info again.

The funny thing is, and thats what pulled my leg is that the same logon happened when I opened another account (other user and password) and opening the fmp database.

It made me blind for the keychain. Thanks for the eyeopener

Rob

Link to comment
Share on other sites

This topic is 5708 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.