Jump to content

Footer problems in FM8


Virtus85
 Share

This topic is 5680 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I'm having a bit of trouble figuring out how to fix this, so I figured I'd throw it out there for people a little more experienced with FM8 than me... :

I'm creating a printable report that has a description of a program, a list of the inputs for the program, and then a graphic showing a sample output.

I put the description in a leading sub-summary, the list of inputs in the body, and the graphic in a trailing sub-summary. Since I want only 1 of these per page, I checked the "page break before each occurence" box on the leading sub summary containing the description.

It looks fine in layout mode and preview mode, but when I go to print, the footer that contains the page number and date is missing from all but the last page printed.

When I turn off the "page break" on the leading sub summary, the footers come back but now data from seperate programs creep onto each others pages... I think the problem is that the page break is making the footer dissapear for some reason, but that page break is essential to the whole layout.

Any ideas on how to keep the page break AND the footer?

EDIT: Also, I have everything set to slide up... dunno if that makes a difference?

Thanks

Edited by Guest
Link to comment
Share on other sites

I'm not allowed to post a copy of the file, sorry.

I checked the version here at my office and its just 8.0v1... Do you think its just a glitch? I'll have to talk to my boss about updating later, but thanks for the tip! I'll see if that fixes my problem.

Link to comment
Share on other sites

Try saving records as pdf and if it shows up correctly it might be your printer driver. If it doesnt show up correctly it might be your page setup .

~Genx

Link to comment
Share on other sites

I tried the PDF export, and interestingly enough it seems as though its also related to the trailing sub-summary. When the list of inputs is too long and the graphic needs to move onto a second page, the footer appears on the page with just the inputs. Other than that, only the last page has a footer.

If its part of the layout and not a glitch, how would I fix that?

Edited by Guest
for clarity's sake
Link to comment
Share on other sites

Well then, if your page setup is right, and it happens when you export to pdf, then its not your printer. Firstly, goto Layout menu, layout settings and setup fixed page margins.

If that doesn't help... its your file, in which case:

Do the following to check if your file is corrupt:

1) Make a copy

2) Recover the copy of the file

3) Try Your report again

Option 2:

1) Seeing as you can't post your file, try and replicate the problem in another file (this will also remove the question of file corruption).

2a) If you do so successfully, post it and we'll try find the problem.

2b) If you think its a real bug (which i don't because its never been brought up before, but that doesn't mean its not) - contact FM Tech Support.

~Genx

Link to comment
Share on other sites

This topic is 5680 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.