Jump to content

Text Wrapping in FM8A


AudreyRae
 Share

This topic is 5391 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I've searched the forums, but have not yet found a resolution to my "text-wrapping" problem... :

The file options DO have "roman" line-breaking checked, yet the "wrapping" continues; displaying text in an off-kilter alignment. Fields that do not have enough text wrap to a second line appear with the correct horizonal alignment.

This is a new FM8 solution for Windows XP displaying data that was provided to me in a *.xls format, which I opened FM8A and then imported into the new solution.

My apologies if I've missed a previous post resolving this issue.

Link to comment
Share on other sites

I do see an alignment problem with the "Star of the..." text and the "Program and Special..." text. If this is the issue, check that the vertical alignment for those fields is set to 'Top', or reduce the field height so it only fits one line.

Link to comment
Share on other sites

Thank you again, but I have tweaked and played with the vertical alignment about a bajillion times (can you sense the frustration : ?) before posting here.

I have also made the field height smaller, but that only makes the wrapping occur in a narrower space.

Link to comment
Share on other sites

Yes, I see the problem. It happens when the content is wider than the field.

As Ender suggested, set the field's vertical alignment to "Top" (under Format > Align Text). Or make the field wide enough to fit the longest value in the list. Otherwise, it will keep trying to align the entire text to the bottom or center line, thus raising it when there is not enough space for that.

Link to comment
Share on other sites

Okay, since you experience the same problem in the Macintosh OS with a very different hardware configuration, we can "eliminate rendering problems specific to... OS or...hardware combination." This is good.

As I mentioned in response to Ender's suggestion, I *have* changed the text alignment back and forth between "Top", "Center" and "Bottom" about "a bajillion times."

No matter what I set the alignment to, in those fields where text is wrapping to a second line it keeps "trying to align the entire text to the bottom or center line, thus raising it when there is not enough space for that" (as you so eloquently stated).

Would you mind trying to change the text alignment in the file I posted in the way you suggested (set the field's vertical alignment to "Top") and see if you experience better results than I?

I never experienced this odd text wrapping behavior in FM2, 3, 4, 5, or 6 (and never noticed it as a problem in FM7--though I barely used 7 at all; just jumped from 6 to 8).

Although it might resolve the problem, I don't want to just "shoot the hostage" here by changing the size of the field to fit the longest/widest value in the list.

Is this expected behavior in FM8? Has anyone else experienced AND resolved this problem?

Link to comment
Share on other sites

Pshhhhh... "Windoze" likes it, too. :worship:

I had previously tried making the field height smaller, but had not also combined that with changing the text alignment to "Top."

Smaller (one line) field height + "Top" text alignment = no more silly text wrapping.

My sincere thanks to you both for tactfully pointing out the obvious--which I generally fail to see. :

Link to comment
Share on other sites

  • 9 months later...

I have found that if the "height" setting in the "Line Spacing" section of "paragraph" settings for the field is 1.00 lines or greater, this won't occur

Edited by Guest
Link to comment
Share on other sites

This topic is 5391 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.