Jump to content

Help Undoing Read Only


Alisun
 Share

This topic is 5679 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I must have accidentally enabled a security feature -

I cannot type in the fields in any of my layouts. This message pops up:

"Action cannot be performed because this field is not modifiable"

I do I undo this? Please help!!

Thanks!

Alisun

Link to comment
Share on other sites

First, by any chance did you copy this file to CD? Because Windows will change it's file attribute to read only. Check that first. Have you been in privileges? And do you have a backup just in case?

This doesn't sound like a usual privilege message. It usually tells you don't have access although I never get these messages because I can access it all.

Link to comment
Share on other sites

Close the file. Right-click and select Properties. At the bottom uncheck 'read-only' on Attributes. Windows, in their (undescribed) type of wisdom, tries to protect us from ourselves. If you store a file on CD, zip it first. Otherwise this will always happen.

Link to comment
Share on other sites

Thanks for your wisdom, LaRetta! That "mostly" worked. There's one field though, that I need to edit that is still saying that is still saying that it is not modifiable.

How do I remeove read-only from an individual field?

Link to comment
Share on other sites

Well I don't know. That should have worked. Did you close the file before you changed the attribute? Maybe that one field CAN'T be modified. Is it a calculation?

Link to comment
Share on other sites

*Yes* it is a calculation. Here it is:

Final Diagnosis=

Case (

finaldiag="1"; "Serous";

finaldiag="2";"Endometroid";

finaldiag="3";"Mucinous";

finaldiag="4"; "Clear Cell";

finaldiag="5";"Undiff. Adenocarcinoma";

finaldiag="6"; "Mixed";

finaldiag="7";"MMMT")

This calculation looks "innocent" to me... Could this calc have turned the field into Read-Only??

Alisun

Link to comment
Share on other sites

Alisun, is it an auto-enter (by calculation) or a calculation field? You can't type into a calculation. BTW, that calc might work more efficiently as:

Final Diagnosis=

Choose ( finaldiag - 1 ; "Serous" ; "Endometroid" ; "Mucinous" ; "Clear Cell" ; "Undiff. Adenocarcinoma" ; "Mixed" ; MMMT" )

Sorry, Forums keeps dumping me...

:wink:

Link to comment
Share on other sites

Aha! Having a calcuation is the problem. A BIG problem. I created it by choosing the field type as "calculation", then I put in the above formula.

So, there's no way to add or edit information in the field?

Right now I have 168 records (patients), with the field Final Diagnosis, but soon I will have hundreds that need their final diagnosis filled in...

The only rememdy I can think of at the moment is to start from scratch with a new, non-calculated Final Diagnosis field, and type in all 168 by hand...

Are there any alternatives ?

THANKS!!

Alisun

Link to comment
Share on other sites

Final Diagnosis contains the data right? It shouldn't be a problem then. But if this was once a standard field with data, it is probably still there. Do you see data in the field? It was probably an indexed calc and your data is fine. Try changing it back to standard text. Then go to Options and Auto-Enter and select 'Calculation'. Your calculation should still be there. Say OK in the calc box then uncheck 'Do Not Replace Replace Existing Values' in the Auto-Enter tab. Does your data display now?

If not, you can set the field with the data again by using the calculation I suggested. If you need help, let us know! :wink2:

UPDATE: Whoa! This calc is called Final Diagnosis! Well you're still okay - it should contain numbers. But you want a DIFFERENT calc to display the text results.

Edited by Guest
Link to comment
Share on other sites

LaRetta, you are brilliant! I was out of the office for two days, but I just re-read your message. I changed my calc field back to standard text. It worked! I can modify the field now. Boy, was that simple.

Thank you again!

Alisun

:thanks:

Link to comment
Share on other sites

This topic is 5679 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.