Jump to content

Restart WPE?


hack-it
 Share

This topic is 5645 days old. Please don't post here. Open a new topic instead.

Recommended Posts

We've got Server Advanced 7.3 running on an X-Serve for several months now; which we use to serve to clients, and then pull to a secondary web server using XML/XSLT and the FX.php plugin.

Within the last couple of weeks (the minute I took off for a week's vacation, natch), we've lost our Web Publishing engine for what appears to be no good reason. Clients still have perfect connectivity, no problems; but the XML/XSLT publishing goes poof on the server--this means that automated imports and updates using XML to the server don't run, etc.

I've tried re-starting server admin, no luck.

I go to the FM SA Web Publishing admin console (http://fmserveripaddress:16080/fmi/config) and got what appeared to be a "status normal" screen, until I clicked the "Restart Publishing Engine" button; then, I get "An Error has occurred: The Publishing Engine is not responding. If the Publishing Engine has not yet been configured, click here to continue."

Any attempt to continue causes a time-out, and I can't proceed.

I tried restarting the web service on the server, no luck.

Is there a way to manually restart the Web Publishing Engine on the FileMaker Server without having to restart the whole server? This is driving me nuts!

Incidentally, I have plans to upgrade to FM8 in a couple of days, but in the meantime, I hate having to kick out all my clients at random intervals to do a cold restart.

Help!

Link to comment
Share on other sites

So... I just got off the phone with Brad at FM Tech support, and he suggested that from the terminal (on the server), I do a sudo command:

sudo SystemStarter restart "FileMaker Web Publishing"

... naturally, it will want the administrative password, but it did the trick, the WPE was restarted, no need to kick clients out. I may cron this to happen twice daily, particularly if the problem persists into our v8 upgrade, and I'll be checking my log files to see what may have precipitated this, but all in all, I'm pretty happy.

Link to comment
Share on other sites

I didn't want to stop the database service -- just restart the WPE. I'd read the manual, but I suppose I'd forgotten in the freak-out of people screaming "OH MY GOD THE WEBSITE IS BROKEN FIX IT NOW!!!!" :P

The most frustrating part of this is that it keeps happening. From the looks of it (via the log files and various online help forums for Tomcat), the problem is that Tomcat is crashing; and it appears that SSL is the culprit--perhaps my Server.xml file and/or workers.properties file doesn't have the right port #s and need to be updated.

Link to comment
Share on other sites

Believe me when I say I already learned that lesson the hard way.

Right now my webmaster and I are combing through all the documentation we can get our hands on regarding port numbers. I'll probably spend tomorrow trying to find old topics about publishing to the web with SSL using FX.php.

Link to comment
Share on other sites

Port 5003 for FM Server

Ports 50003 and 50006 for the SAT Tool (but not with NAT)

Pots 16008 thru 16018 for the WPE, depending on the configuration.

Standard SSL ports for Apache or IIS.

If the web server is using SSL, the WPC must refer to the web server by the name of the certificate, not by IP address.

HTH

Steven

Link to comment
Share on other sites

This topic is 5645 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.