Jump to content

recovering damaged file


This topic is 5602 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Is it the end of the road when having tried to recover a d/b it still will not operate ok?

Mine opens ok but any attempt to work on a field instantly brings up "encountered a problem"

All is not lost as i have a back up just one day old but for my own knowledge i would like to know what else i could possibly do to try recover use of this d/b


Link to comment
Share on other sites

The Recovery Function tries to fix your file enough so that you can get at your data. Do not continue to use the file. Instead, export the data to text files, and import the text files into a pristine copy of your file.

If you don't have a clean copy of your database, then you should recreate it,


Link to comment
Share on other sites

Hello Lee


I will try what you suggest ,I know that there are some 15 records more in the d/b than currently shown on the screen that opens .which as i said as soon as you touch any field --bang you are locked out.

The thing may be beyond help any way as it occurred whilst i was working on files only remotely connected to the d/b


Link to comment
Share on other sites

... Either that or run through every single one of your scripts, all your layouts, check all your relationships are functioning properly, check all your calcs are evaluating properly ... and then replace all the things that FM removed in order to get your file open.

Link to comment
Share on other sites

Yes, I used the term pristine because you want to use a copy that has never failed. This could be the last backup prior to a failure, or in some cases, the developer keeps a copy that has never been used, and uses a copy of it when the file fails.



[color:red]Genx, I wouldn't do that. The corruption could still be there on a layout, or in the data. That was one of the reasons I suggested Text Export.

Link to comment
Share on other sites

I understand, and that is why I said a Pristine Copy. This implies that it is a copy of a File that has never been used, or one that has never failed, and dates back a while.


Link to comment
Share on other sites


thanks guys I have tried your suggestions and I can restore all the data except 10 known entries that just doesnt appear.As i said earlier no real damage was done as a backup current to ealier in the day was available ,the whole excercise was basically for any actions that i should take if similar occurred in the future.What made it all seem odd was the way the error was activated as soom as any field was clicked on,though i could look at some tabbed layouts and its data ok


Link to comment
Share on other sites

This topic is 5602 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Tony Morosco
      I'm a botanist, and the tables I am working with are for tracking botanical garden collections. The data represents plants in the garden, and the plants are tagged and show up in the database.  The tables I am working with were created in FMP 7, and I'd like to open them up in FMP 11 (or later.)  The system hasn't been used in years, but still has valuable information.
      One of the tables is giving me problems using the FMP convert and recover commands.
      These tables are all inter-related.  The main table is the Accessions table, which contains records for all of one kind of plant, from the same source, received on the same date.  It is basically a museum standard.
      The other tables are related to each other through this one main table.  The Species table is related to the locations table through the Accessions table. 
      (i.e.  table A relates to table C through the table B, the intermediary)  
      From the Locations table, we can't see the the species information unless the accessions table is present.
      When issuing the open command on the main table to convert the database to FMP 11, I get the message:
      "Accessions.fmp7" is damaged and cannot be opened.  Use the Recover command to recover this file. When using the Recover command from v. 11, I get another message:
      WARNING: problems were detected while recovering the database.  Please review the Recover.log file to see where problems were found and their severity.  The recovered file should NOT be used going forward; copy only the most recent work from it into a backup copy of the original file. Recovery results:   File blocks: scanned and rebuilt 563 blocks, dropped 214 invalid data blocks.   Schema: scanned fields and tables, 1 items modified   Structure: scanned; 1 items modified   Field indexes: rebuilt  
      Opening the recovered database, there are only three records present.  There should be hundreds.  So obviously I am looking on how to wrangle this database open.
      I've attached the log file here, as well as the database structure map.  
      The other files have converted just fine.  But since the main table won't open, we are kind of stuck.
      I can share the files with you through Dropbox or whatever, if needed.
      Please let me know any thoughts you have, either basic or advanced.  And ask for any clarifications or additional questions.   :-)  

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.