Jump to content

File not found (WEB & CDML)


This topic is 8428 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi, perhaps someone can help me. This is what I have.

Running FM 5.0.6 in a iBook, system 9.1

I have published my invoices database, I recall data from it using CDML.

Works fine until I change to a different layout, when I submit a new search or simply a refresh from the browser and a error message appears, it says "File not found" and the error is "Format file not found"

I been playing with it , I found out that is a field (or group of fields) that are "corrupted" I deleted that field and created again, works fine for a few moments but the error keeps returning. If I "hide" (move the fields to the hidden part of the layout) I can access the search page, as example, but if I return the fields to their previous place doesn't work any more, is like if that field deactivates the web companion.

All the databases that are related have activated the web companion.

Any idea what could be wrong, any idea to correct the problem without redoing the databases again?

Thanks

[ June 11, 2001: Message edited by: ernest_mty ]

Link to comment
Share on other sites

You are using instant web publishing, I'll bet. What browser are you using? What style is web companion set to display the pages as?

I'm not familiar with instant -- few people on the forums will be familiar with it because it's quite limited. Most change over to "custom" publishing and write their own CDML because it allows so much more control and possibilities.

I've heard that the choice of "style" that instant is configured to is significant, as not all styles are supported by all browser types and versions. I believe the "plain" is most compatible.

Link to comment
Share on other sites

Thanx Vaughan

I'm not using instant web publishing, just CDML and Explorer 5.

As I said before, as soon as I change from one layout to another (I can't avoid that) I can't no longer connect with the database, if I close the DB and open it again but in the original layout works again. Is like if I closed down the application.

This problem doesn't show up if I'm consulting via Instant web publishing. I have installed the latest Web companion.

Any idea?

Link to comment
Share on other sites

You say "change from one layout to another" -- what do you mean? If you are accessing through the web, do you meaan "go from one page to another"?

Are you working eith the database on the server while it is hosting and sharing the database through Web Companion?

Link to comment
Share on other sites

You say the fields are related.....check your relationships and field setup (double click on it in Layout Mode) on the second database -Lay (I assume you've split your fields accross multiple layouts in your database). I've had problems where I've had errors in this area and it causes all sorts of odd errors.

Other than that you could Recover the database and check your HTML / CDML for typos (again! smile.gif" border="0 ), I've noticed Dreamweaver and Go-live append a number after hidden form element names if you copy and paste worth checking!

Good Luck

laugh.gif" border="0

Link to comment
Share on other sites

To Vaughan,

Thanx and Yes I'm working both in the database and the web, when I said changing layouts is in the DB. But also the CDML calls this layouts, so in any way the error can't be avoid it.

I was checking the Filemaker database of technical issues on the web. "File not found" refers to an error coming from the Claris XTND and XTND preferences, I get rid of both and reinstall them but nothing changes, other errors reported say that is a problem from the web service, in this case the web companion, but it says nothing in how to work it out. I've reinstalled the FM and nothing either. This is interesting, I move the DB's and htmls to a another machine and guess what? the error doesn't happend there. So I figure probably is an extension, I did some testing playing with various sets of extension but nothing so far, both systems have OS 9.1.

Well we are closer than yesterday but not there yet. Comments?

To scratchmalogicalwax

Thanks, yes I have one relationship but only for autoenter lookups.

I did recover the DB and also working with no records (just to show a search page) but nothing there. I also did again the html page, with no success.

I going to test again in the other computer and bring the Claris folder and application from the other computer to mine and see what happens.

[ June 13, 2001: Message edited by: Ernest_mty ]

Link to comment
Share on other sites

Hi you guys

I found out what was causing the problem.

I have installed the Script Scheduler plugin, from wmotion, aparently causes a conflict with something else, I don't know yet, I've been trying deactivating other plugins but not conflict yet. I've installed a fresh copy of the plugin but not luck either. I said aparently because I have installed that plugin with some customers, accesing via CDML, and they don't have the problem, and they are using also FM 5.03 with Web Comp. 5.0.6.

I'll go to Wmotion, let see what they say.

Thanx

Link to comment
Share on other sites

  • 2 weeks later...

Just for the rcord, the layou that web companion uses is determined by the -lay CDML tag. It is completely independent of the layout that a user might be viewing on the hosted database.

Also for the record, it is a BAD idea to be using the database while it is being hosted and shared through web companon. Web Companion "remote controls" the database and will change modes and layout as it peforms ewach user's request. Changing into layout mode will prevent WC from accessing the database: so will being in define fields and maybe scriptmaker. If another users has to work on the database, put them on another machine as a guest.

This is what we mean when we say "dedicated server" by the way: the machine sits there and just serves the databases, it's not used for ANY other purpose -- especially not to have a user at the console doing work.

Link to comment
Share on other sites

This topic is 8428 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.