Jump to content

Problems installing FMSA to IIS w/ Web Publishing...???


This topic is 6164 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I know what the problem is but I don't know how to fix it. Everything is running just fine except that when I try to configure IIS with FMSA it says it can't find the web server.

The reason for this is because when I configured my site in IIS I actually disabled the default site and created a new one. Take a look at this screenshot to see what I mean: http://www.angelleye.com/temp/iis.jpg

If I disable the angelleye.com site here and enable the Default Web Site, then the FMSA configuration finds it successfully.

The problem is I already have the SSL configured for this current site and don't want to mess with changing all of that.

How can I make FileMaker look at the correct web site within IIS? I've tried using localhost and I've also tried using the domain name. I've tried both 80 and 443 (SSL). It simply thinks IIS isn't running because the default web site isn't enabled.

I figured it might have something to do with the Identifier and I found an article on how to update this (http://curdt.wordpress.com/2007/06/22/changing-the-identifier-of-a-website-in-iis/). However, upon doing so I could not restart that web site anymore because it said it didn't recognize the path.

So I'm stuck. Any information on how to fix this would be greatly appreciated. Thanks!

Link to comment
Share on other sites

Ok, I deleted the default web site from IIS so only the angelleye.com site shows up in there now. I then went back to configure web publishing and it worked this time.

Now, even the links on the test page works to show PHP and XML is configured correctly.

However, when I go to http://localhost/fmi/config/ I get an error:

HTTP Status 404 - /fmi/config

--------------------------------------------------------------------------------

FileMaker Server has encountered an error:

The requested resource (/fmi/config) is not available.

If the Server Launch Page is not available, visit the FileMaker Website for more assistance.

So now I think the problem is that FM had configured a virtual directory or something inside that default web site instead of in this one. Now that I deleted the default site, though, I can't look to see what directory that was or now to set it up.

:)??

Link to comment
Share on other sites

hmmm...

if I try

http://localhost/fmi/xml/fmresultset.xml?-db=Auctions&-lay=Auction%20Layout%20Main&-findall

then I get prompted for un/pw as expected. in FM I've got 1 un setup with full access and another setup for web apps that has XML/XSLT/PHP enabled for it only.

I'm trying both of these and it's not allowing me access with either. If I use the one with full access I end up with the filemaker provided 401 forbidden page with the dark blue header line. If I use the other account that is setup with web access only then I can't even get that...i just get an IIS error page that says I don't have access to the page.

What am I missing?

Link to comment
Share on other sites

This topic is 6164 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.