Jump to content

Changing group membership on Tiger OD Server requires reboot of Filemaker 9 Server to update


This topic is 6071 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a FileMaker 9 Server (running on Mac OS 10.4 Tiger, not server) that is set up to externally authenticate to our Mac OS 10.4 Server (configured as an Open Directory Master).

For the most part everything works great, I added the necessary groups (fm_supers, fm_admins, fm_casemanagers) to the Tiger Server, assigned the proper groups to the users and everything worked perfectly.

The problem comes when I need to change the level of access an existing user has. For instance, I removed one of my members from the fm_casemanagers group and then assigned them to the fm_supers group (the user was not logged into any database while I made the update to group membership).

When the user logs back in for some reason FileMaker is still picking them up as being in the fm_casemanagers group rather than the fm_supers group. I tried shutting down and restarting the particular database and it did not help, I also tried stopping the FileMaker database server and restarting it but that did not help either. So far the only way I can get the FileMaker Server to recognize the group membership changes is to reboot the FileMaker Server.

Does anyone know what I need to do to make these updates just work without the need for a FileMaker Server Reboot. I must be missing something obvious here.

Thanks in advance for any help that can be provided.

Edited by Guest
Link to comment
Share on other sites

In the domain search path on the FileMaker Server machine be sure you are not selecting automatic option. Specifically select the domain controller. See if that helps any.

FWIW, OS X is notoriously twitchy about these things. They must frequently be rebooted for changes to work.

Steven

Link to comment
Share on other sites

  • 1 month later...
  • Newbies

I am having the same issue where the FileMaker Server 8.0v4 running on Mac OS X 10.4 needs to be rebooted when you change a users Active Directory group. Otherwise FileMaker continues to use the previous group.

Our domain search path is not set to automatic. Has anyone been able to fix this issue? Thanks.

Link to comment
Share on other sites

This topic is 6071 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.