Jump to content

Summaries not printing


Oldfogey

This topic is 6077 days old. Please don't post here. Open a new topic instead.

Recommended Posts

What have I done this time?!

I have a simple(?) report, printing Sub-summaries above and below the Body plus a Footer. Looks fine in Preview mode but, when I actually print, only the Body and Footer print. The Body is a bit tricky. It's a three row portal with sundry objects behind the portal, which print when a portal row is empty. However, I cannot see why this should have any bearing on the problem. (And there are excellent reasons for printing a portal.)

I've triple-checked the sort, all the relationships, text formats, and everything else I can think of.

It was working until I corrected an error with the Portal relationship. Perhaps I should mess it up again?

Any other suggestions would be gratefully received - preferrably before the throat-cutting.

Link to comment
Share on other sites

I did! I do not see how a relationship affecting a portal can influence the printing of summaries, which have no fields relevant to the portal relationship.

I think I might have solved the problem. I'd forgotten that FMP closed (long story) while I was working in the layout. Looks like that horrible word 'corrupted' and a re-build of the layout. Oh, well, it only took half a day and let's hope it was just that layout.

Thanks, Vaughan, for opening the floodgates of my memory. An even earlier issue, which didn't bother me all that much at the time; before I'd even touched it much, it wouldn't PDF the full layout - just the Body. Oh, !#^$@$&%@$$!#%@#~!. I copied this layout from a V8 version of a V6 file. Bloody V6-V8 elves!!

Maybe the Moderator will remove this whole thread. Or maybe leave it as a lesson in problem non-analysis. :(

Link to comment
Share on other sites

Well, well. Live and learn. What a relief to know that I'm not so stupid after all - just ignorant.

As each record uses a single page and I'm mean, I've been printing 'Current Record' to save trees. Tried printing 'Records being browsed' and all is well. :tigger:

How come I was so sure it had been working? I hadn't fixed the sub-summaries properly at that stage.

Link to comment
Share on other sites

This topic is 6077 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.