Jump to content
Sign in to follow this  
Atalanta

File Disappeared While Working On It

Recommended Posts

This was a doozy. I am converting our files from FM 5.5 to 8.5 using FileMaker Advanced 8.5v1 (currently downloading the updater). I am using an iMac running 10.5.2 with a 2GHz Intel Core 2 Duo.

I had just finished tweeking the last script in one particular file (I'll call it Fred.fp7). Next step is to go to the folder and change the color label on the file so I can quickly see which files I've modified and which ones I have yet to do.

I have the folder sorted by date modified so the ones I'm working on will be at the top of the list. Fred.fp7 was missing from the list.

I went into Fred.fp7 (which was still open) and added a global field to a layout so I could see where the file was (could it have moved somehow?) According to Get(FilePath), Fred.fp7 was where he was supposed to be.

I did a find and could find Fred.fp5 and Fred.fp3, but no Fred.fp7. I searched for files of kind FileMaker and didn't find the proper Fred. I did a search for hidden/invisible filemaker files and still no sign of Fred.

I quit FMA 8.5 and then restarted it. Now Fred.fp7 is totally missing. When I open a file that is related to Fred.fp7, it can't find Fred.fp7. My next step (after posting this) is to restart my Mac and see if he "magically" appears.

Fortunately, Fred was not one of the more complicated files in this batch and I can redo the modifications I did. But I am worried about this happening again. And what about giving this solution to a client, what do I do when this happens to them (and don't give me the backup lecture, I will be restoring from a backup).

Share this post


Link to post
Share on other sites

That sounds like a nightmare. Sorry you're living it. I guess a couple of things might have saved you. One was to have saved the file with a new name before you closed it. I'm guessing that you had a bug work its way into your OS or FM app. Why not do a find for any file on your computer that has today has its creation date? It might not have the right extension so it won't be recognized as a FM file. I'd also use the Terminal to view the suspect folder with the command 'ls -hal' to see if its really there or not.

Share this post


Link to post
Share on other sites

I did try to save it under another name, even in a different location and that didn't work (it didn't show up in the folders). Did searches for any files created/modified with the "proper" time stamp, nothing there either.

I was hoping that someone could post some instructions on using terminal, I'm not very well versed in using UNIX or terminal.

Share this post


Link to post
Share on other sites

Too late, LOL

This question was asked a year ago.

Lee

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Similar Content

    • By Tumma K
      Hello, All!

      I am an aspiring developer for Filemaker. The company I work with is stuck in the past working off of Filemaker Pro 4.1

      I was given the task of bringing us up to Filemaker Pro/Server 13. So far my conversion prototypes are successful but we recently had a layout issue that can only be fixed in versions 3-6 (as the file is an .fp3) I work off of a macbook while our network is all Windows 7. In order for me to repair the layouts without tampering our active database, I decided the best option is to repair a copy of our solutions off the network. Unfortunately, when I go to download the trial version of Filemaker Pro 6 off of the respected website, the file is corrupt! I've tried multiple times, with different extraction apps and in different directories.

      My question is;

      Does anyone know a place where I could obtain version 6 (or better yet, 4.0) for an OSX computer? I've looked everywhere!
       
      Thank you for your time,
      Tumma K.
    • By MrEddByrnes
      I'm hoping my question can have a happy ending. In the mid-90's, I purchased Filemaker 3. When Filemaker 5.5 Pro was released, I bought the update CD, which requires the user to either have FM 3 installed or to have the installation CD for FM 3. I've used it all these years, most recently with Windows XP Pro, and it has worked just fine. The databases I began with were long ago converted to FM Pro 5.5 databases.
       
      I'm still using FM Pro 5.5 on a laptop with WinXP Pro, but in 2013, I purchased a PC with Windows 8. I haven't been able to install FM 3 on it, therefore can't install FM Pro 5.5. I am retired and rarely use Filemaker, but I have a few Filemaker databases I'd like to add to my Win 8 machine. I don't feel it's worth upgrading FM for the sake of using a couple of databases.
       
      Has anyone else run into this situation and/or have a (possible) solution? Is there perhaps any other software that can read FM 5.5 databases? Thanks in advance for your help.
       
    • By bmill
      I am using a custom filemaker solution for medical office billing written with fp5 running on a mac with snow leopard. In addition, I have a patient management db (which I wrote) that is linked through pt. ID number to the billing program allowing transfer of some demographic information (name, DOB, etc).
       
      Other than being limited by hardware restrictions, the billing program serves our needs for now and upgrading to fp12 will take some time (and money).  In the meantime, I am upgrading my pt. management program to fp13 and would like to move new patient demographic information from the billing program ( fp5 running on snow leopard through Parallels) and the new pt management program ( fp13 running on OS X 10.9) on the same mac.   
       
      Ideally, demographic information would be entered once into fp5 and then a scipt would make the data available for fp13.
       
      Any ideas on how to make this work?
    • By randyinla
      Hi, can anyone tell me why my on-line database might have stopped allowing me to delete records?  All of my access privileges and passwords are correct.
       
      thanks!
    • By randyinla
      Hi, I still use filemaker 5.5 and am very happy with it and don't want to upgrade.  Does anyone still host filemaker 5.5?  Thanks!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.