Jump to content
Sign in to follow this  

Question mark appears on data entry

Recommended Posts

Probably a Windows prob, not Filemaker but here goes...

I made a DB for a friend in FMP9 on my mac.

I imported most of the data in FMP9 on my mac.

She only has FMP 8.5 and uses Windows.

When I handed it over onto her laptop we tested and it worked and she added some more data.

When she got it home and put it on the Windows desktop machine it opened and looked OK. (She insists its Windows XP with SP2).

When she tried to edit existing data or add new data to some text fields, regardless of what she typed, she only got a ? in the field. I'm pretty certain that space and formatting are ok.

So she zipped it and sent it back. And I opened it (now using my FMP10 trial) and sure enough those fields she had tried to edit had a ? in them.

When I tried to edit them I could do so without a problem.

1. To test it I did a search on ? in fields that had a ? thinking that the ? meant invalid data. Did not match any criteria. So I tried "?" and it found those records with fields that had the ?

2. So I used the new recover command in FMP10 and it recovered/rebuilt the file and found no errors, yet the ? was still there in those fields that I had not yet corrected.

Any suggestions? Reinstall Windows? Buy a Mac? Upgrade to FMP9 or FMP10?

Share this post

Link to post
Share on other sites

It sounds like the Transfer of this file between those machines has changed the Finder Access (it happens sometimes). Have her check the file at the Finder level, and see if it show Read Only, instead of Read and Write.



Share this post

Link to post
Share on other sites

Thanks Lee, Looks like you're right.

Privileges on my mac says 'read & write' for me, but 'read only' for 'everyone' and 'unknown'.

However I checked other databases I've done, they also say the same and they are out there working?

Anyway I've sent her a message to check the permissions & will report back.



Share this post

Link to post
Share on other sites

Ok she tells me that under properties 'Read only' is unchecked, 'Hidden' is unchecked, and 'Archive' is checked.

(There is no 'Security' tab, only a 'General' tab)

Are we in the right place?

BTW she's now back on the laptop and any attempt at data entry results in :):)


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.