Jump to content
Sign in to follow this  
reinlook

line breaks

Recommended Posts

Hi,

I have a problem with creating new records. After this command:

$addCommand->setField('FieldName',$myRecord->getField('FieldName2', 0));

there are no line breakes in the field 'FieldName'.

'FieldName2' contents some line breaks and I wont to have them in the 'FieldName'.

Am I doing something wrong?

If someone could help me, I would be very greatfull.

Rafal

Share this post


Link to post
Share on other sites

if it's not a typo in your post, the semi-colon between $myRecord-> and getField(

is a PHP syntax error

If that's not the problem what error message is php and/or the Filemaker object throwing?

Share this post


Link to post
Share on other sites

it was a typo. the syntax is ok.

no error message is throwing by php and/or the Filemaker.

I've tried to do it with the nl2br function

$addCommand->setField('FieldName',nl2br($myRecord->getField('FieldName2')));

and the result look like this:

some text,

some text

Share this post


Link to post
Share on other sites

That's what nl2br() does. It's generally used for printing content to the screen, because HTML ignores most white-space including carriage returns.

Exactly what problem are you having?

Is the record created?

If yes then does `FieldName` contain a value?

If yes how does that value differ from what you expected?

You said the were no Filemaker errors are you running the following code to check for them?




$result = $addCommand->execute();

if (FileMaker::isError($result)) {

	echo "Error: (" . $result->getCode() . ") " . $result->getMessage(); 

}

Lastly does `FieldName2` contain any non latin characters?

is so try this

http://fmforums.com/forum/showtopic.php?tid/201486/post/318728/

Share this post


Link to post
Share on other sites

It's tough to tell exactly what you are trying to do from a little snippet of code, but I can tell you that working with line breaks with FileMaker and PHP is a little tricky.

When you have a FileMaker field that contains line breaks and your pull that data with PHP, it shows up on the PHP side as n or the new line character.

If you want to use PHP to set a FileMaker field with line breaks in it (e.g. a checkbox field is the most common example) then you have to use the r character sequence.

Bear in mind that I am a mac/linux dude, so YMMV if Windows is involved. I just wrote an article for Advisor that touches on this topic, but I am not sure when it will be released.

HTH,

j

Share this post


Link to post
Share on other sites

I'm struggling with exactly this but replacing n doesn't seem to be working for me.

I'm pulling a text field that includes line breaks out of FileMaker via getField(). I've also tried getFieldUnencoded() and I seem to get the same result.

I lose all of my line breaks when I pull the data and echo it to a web page. I tried using str_replace() to replace n with

but that isn't working.

Any info on how to get this to work would be greatly appreciated. Thanks!!

Share this post


Link to post
Share on other sites

Use nl2br() instead of str_replace() to replace natural line breaks with

It will catch all of the different OS idiosyncrasies

Share this post


Link to post
Share on other sites

Hi Rafal

Getting line breaks from an HTML text area into FMP fields can be affected by the charset of the page.

Check that your charset is UTF-8 in the line within the html

element, like:

You can also try adding UTF-8 directly to your form, like:

nl2br() is the PHP function for getting line breaks that exist in FMP fields to display as separate lines in HTML

"nl2br" stands for NewLine character (e.g. n or r) TO line BReak (or

tag)

HTH,

-Joel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By jayivan
      I am working on an API integration from FileMaker 17 to Emma. Generally when I work on a new API, I get the curl working on the command line and then translate that into FM. But I've hit a roadblock with one particular API call while my other API calls to Emma are successful. (In the example below, I substituted out sensitive data with all caps.)
      From the command line, the code is:
      curl -u USER:PASS -H "Accept:application/json" -H "Content-type: application/json" -X POST -d '{"fields": {"name_first": "TESTFIRST","name_last": "TESTLAST","eligible": "false","expiration": "@D:2019-06-30"},"group_ids": ["GROUPIDNUMBER"],"email": "EMAIL@EMAIL.COM","opt_in_confirmation": "false"}' "https://api.e2ma.net/ACCOUNTNUMBER/members/signup"
      This command is successful.  The server responds with the individuals' emma id and group confirmation. 
      This fails using Insert from URL within FM though. While eventually I'll use FileMaker fields for an individual record's names, email, and expiration dates, I did not use fields in my testing in order to duplicate the command line exactly. In Insert from URL:
      The URL is "https://api.e2ma.net/ACCOUNTNUMBER/members/signup"
      The curl option is "-u USER:PASS -H \"Accept:application/json\" -H \"Content-type: application/json\" -X POST -d '{\"fields\": {\"name_first\": \"TESTFIRST\",\"name_last\": \"TESTLAST\",\"eligible\": \"false\",\"expiration\": \"@D:2101-06-30\"},\"group_ids\": [\"GROUPIDNUMBER\"],\"email\": \"EMAIL@EMAIL.COM\",\"opt_in_confirmation\": \"false\"}'"
       
      Can anyone identify the problem or suggest a workaround? My experience with API integration with FM is limited, but anything I could get working via the command line, I've been able to get working within FM until this.
    • By Richard Carlton
      In this Coaches' Corner tip, Richard Carlton challenges you to go learn how to use RESTful services!
      Get up to speed with the FileMaker Pro 16 Video Training Course! 
      Top Rated Course by FileMaker Expert, Richard Carlton.  
      http://learningfilemaker.com/fmpro16.php
      Experience Richard's dynamic and exciting teaching format, while learning both basic, intermediate, and advanced FileMaker development skills. With 27 years of FileMaker experience and a long time speaker at FileMaker's Developer Conference, Richard will teach you all the ins and outs of building FileMaker Solutions.  The course is 50 hours of video content!
      Richard has been involved with the FileMaker platform since 1990 and has grown RCC into one of the largest top tier FileMaker consultancies worldwide. 
      Richard works closely with RCC's staff: a team of 28 FileMaker 
      developers and supporting web designers. He has offices in California, Nevada, and Texas.

      Richard has been a frequent speaker at the FileMaker Developers Conference on a variety of topics involving 
      FileMaker for Startups and Entrepreneurs, and client server integration.

      Richard is the Product Manager for FM Starting Point, the popular and most downloaded free FileMaker CRM Starter Solution.

      Richard won 2015 Excellence Award from FileMaker Inc (Apple Inc) for outstanding video and product creation, leading to business development.

      RCC and LearningFileMaker.com are headquartered in Santa Clara, CA.

      http://www.rcconsulting.com/
      Please feel free to contact us at support@rcconsulting.com
      If you want to explore building iOS apps for iPhone or iPad and deploying those out to the Apple App Store.
       
      Here is a video introduction to our iOS App Training https://www.youtube.com/watch?v=cVxQe_yAshw
      Looking for FM Starting Point free software download: http://www.fmstartingpoint.com
      For More Free FileMaker Videos Check out http://www.filemakerfree.com
      Visit http://www.learningfilemaker.com for all facets of FileMaker Award Winning Video Training.
      Please Visit Our Channel: https://www.youtube.com/user/FileMakerVideos Please Subscribe While There.

      Please Comment, Like & Share All of Our Videos.

      Feel Free to Embed any of Our Videos on Your Blog or Website.
      Follow Us on Your Favorite Social Media
      https://www.facebook.com/FileMakerVideos
      https://twitter.com/filemakervideos
      https://plus.google.com/+FileMakerVideos/videos

      Filemaker Pro 16 Training Videos
      FileMaker 16 Videos
      Filemaker Pro 16 Video Course
      #FileMakerVideos
      #FileMakerTrainingVideos
      #WhatisFilemaker16
      #FilemakerPro16Training
      #Filemaker16VideoTutorial
      #FilemakerPro16Videos
    • By docasar
      Hello,
       
      I am trying to connect to our current database with our shipping company so I can update the status of the delivered orders. To do that, I am currently using insert from URL and then parse the code to extract the info I need. However, I believe there should be a cleaner and safer way to do it using webservice.
      So I downloaded the documentation and looks very straightforward to set and I have been able to set up the POST and send it getting the data as XML using POSTMAN (as very well explained here:  http://www.filemakerprogurus.com/filemaker-api-integration-salvatore-coleangelo/ ) and also in the great post by luminfire https://luminfire.com/2017/06/12/curling-filemaker-16/.
      However, when I try the same parameters on my script in filemaker, I get all the time an error saying that something like  "Entry XML Schema/template it is not loaded correctly". Following the documentation of the API I see that on Postman I need to insert on the Body RAW some kind of code that looks like this: 
      <?xml version='1.0' encoding='UTF-8'?>
      <SeguimientoEnviosRequest xmlns:xsi='http://www.w3.org/2001/XMLSchema-instance' xsi:noNamespaceSchemaLocation='SeguimientoEnviosRequest.xsd'>
      <Solicitante>x</Solicitante><Dato>xxxxxxxxxxxxxxxxx</Dato>
      </SeguimientoEnviosRequest>
      but I don't know which settings I have to do on my script to make the call work.
      Any suggestions as to where to put this info so the can be passed with the CURL? I am a bit desperate now because I see the amazing possibilities that the interaction with the web service may bring but I can find a way to make it work...
      Thanks a lot for your always invaluable support!!
    • By jpons
      Hi,
      I want to enable the Cloud REST API, but I am afraid that I "dismissed" the notification message that allowed me to do so. How can I enable the RESP API on my cloud instance?
      Thanks,
      -J
    • By JTSmith
      OK, I'm using FM16 and trying to figure out an API call.  I'm not an expert when it comes to APIs.
      I have a shopify store, and I can use Insert from URL to get the JSON info on each order.  I want to be able to "PUT" and upload parts of the order.  Every order has a "Note" field that I can add notes.  Per the shopify API documentation, to add an order note, you do the following:
      Add Note to order
      PUT /admin/orders/#{id}.json { "order": { "id": 450789469, "note": "Customer contacted us about a custom engraving on this iPod" } }  
      Can someone help me with what I put in the cURL options area?  Any help would be appreciated.  I think I have the URL and Target figured out.  Thank you!!
  • Who Viewed the Topic

    10 members have viewed this topic:
    BertWeijs  fileman922  Ed@  Arkarna  normanicus  Ronji  andries  dennis_em  szto  Kaiviti57 
×

Important Information

By using this site, you agree to our Terms of Use.