Jump to content

Timestamp Uses Server Time


Andrew C
 Share

This topic is 4332 days old. Please don't post here. Open a new topic instead.

Recommended Posts

The timestamp fields for the database seem to be using server time, which is different from our local time. Is there a way to make the filemaker file use server time +3 hours? Or is there another solution? If I use calculation fields then all of the old data will be displayed as the wrong time. This is for a lot of different fields, so I'd rather not go down that road.

Thanks

Link to comment
Share on other sites

Are you using Get( CurrentHostTimestamp ) or Get( CurrentTimestamp ) in the calculation? Also, is the calculation being performed on the client or on the server?

Link to comment
Share on other sites

For the most part they are just Timestamp fields with auto-enter creation date or auto-enter modification date. I would not want to use Get(CurrentTimestamp) because we have some people who travel but still want the timestamps to be eastern time.

For creation date, I guess my plan will be to disable auto-enter timestamp, and then insert it through the record creation script with Get (CurrentHostTimestamp) + _cTimeDifference, where _cTimeDifference will be a constant in case we decide to change hosts or host it ourselves some day. Unless there is a better solution. It will be a hassle to change this in about 20 different places.

Modification timestamp will probably be a little more difficult.

Link to comment
Share on other sites

This topic is 4332 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.