Jump to content
Sign in to follow this  
JTSmith

Insert PDF Greyed Out?

Recommended Posts

Am I missing something simple? In FM12, when I go to the container field the 'Insert PDF' option is greyed out...

Any advice/help would be greatly appreciated!

Share this post


Link to post
Share on other sites

Which operating system? Are custom menus in use? Is the file converted from FMP 11 or earlier?

Share this post


Link to post
Share on other sites

I'm on Windows Vista Home Premium, and I just upgraded to FM12, and converted my database built in FM11 to FM12. No custom menus...

Thanks.

Share this post


Link to post
Share on other sites

Isn't there a "allow interaction" checkbox on the Inspector that might be the culprit?

Share this post


Link to post
Share on other sites

I tried that, and it still is greyed out... weird

Share this post


Link to post
Share on other sites

Create a new file in FMP 12 and see if the problem still exists.

Share this post


Link to post
Share on other sites

FM12 Go works like a charm on this but not Mac or Windows. PDF remains greyed out and does not work, interactive or otherwise. Definite bug here for sure. Any workaround would be terrific.

Share this post


Link to post
Share on other sites

Ya, I realized I'd have to start a new database. It doesn't matter much, I was hoping it would be little thumbnails and I could "pop up" to see something. I store contracts in them, and sometimes I need to check one thing or the other, but the way they are stored makes it a pain.

Thank you everyone though for the advice/help.

Share this post


Link to post
Share on other sites

Perhaps use "Insert file" and then just add the pdf? It seemed to work for me just now.

Share this post


Link to post
Share on other sites
Isn't there a "allow interaction" checkbox on the Inspector that might be the culprit?

Thanks for posting that bit of information.  I couldn'get my pdf to show properly without it.

Share this post


Link to post
Share on other sites

Can anyone shed any more light on this?

 

I have a file that was converted form FM12 to 13.  Whilst I never tested the insert pdf functionality whilst it was in 12, in 13 the insert PDF option is greyed out.  I do have the option for interactive pdf switched on.

 

If I create a new database in FM13 I can see the insert pdf option.

 

Any thoughts would be appreciated.

 

Russell

Share this post


Link to post
Share on other sites

Think I have a solution to the greyed out 'Insert PDF'  I have been having the issue on windows 7,8,8.1 & 10 as well as MAC OSX

If you associate a container field to an edit box it does not work right, I have to drag in the container from the field picker Dialogue

Let me know if this works for you

Edited by Angelssword

Share this post


Link to post
Share on other sites

I have this same problem and cannot clear it by any of the so far suggested methods. It is very frustrating!

I am running Filemaker 14 Pro on a Mac with OSX 10.11.6 (El Capitan).

 

I have checked with the inspector that the PDF option is selected. The edit box field in Inspector is greyed out so cannot be selected by mistake.

I have the latest version of Adobe Reader installed and set as default viewer (though I do not see why I cannot use Preview).

Yes, I can insert the file instead of inserting a PDF, but then I cannot open it from the layout (the only way of accessing it then is by exporting it first, then opening the exported file).   

Share this post


Link to post
Share on other sites

When you click 'add a file', choose your file but at the bottom there is a box which says 'save only reference to file' and save it. Now in the database whenever you double click the box the .pdf file will open.

Share this post


Link to post
Share on other sites

Actually, "save only Reference" isn't the ideal solution since in a multi-user environment you'd need to ensure that each user can access the path to the file. I find it best to have the file stored on the server, and use external storage for containers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.