Jump to content
Sign in to follow this  
fmbug

Working with Global Fields

Recommended Posts

Dear All,

Here I am working with Global Fields, but I stuck on a very logical error.

The scenario is, In my global table, I have only one record. I am updating the records with the data of some another table, something using like, set variable and set fields, script steps. These all are working fine. But the problem is that, my file is on FMS. and I am hosting the file using different users. The updated data is visible on only that machine where it is getting updated. But not getting updated on another machine.

For Example: Suppose there is only one record in Global table.. having value in the field Country as Australia in First machine. From second machine I am updating it to America, still having the number of records 1. But in first machine it is still Australia. Means in a single records, two different data is existing. Please help me I am very much confused that how it is happening. As per concept, only one record can be there in Global fields and it is same for all.

Share this post


Link to post
Share on other sites

Do not use global storage for the fields in the global table. As you have found, globally stored fields are unique to each user in a multi-user scheme. Simply uncheck the "Use global storage..." checkbox for all fields in this table. Your single-record table will then perform as you expected. Just another example of how slippery the English language can be.

The single-record table was conceived to work around this attribute of globally stored fields. If it helps, think of this table as a preferences or settings table, instead of global.

Share this post


Link to post
Share on other sites

It is not working. Please suggest me some another way.

Share this post


Link to post
Share on other sites

Hey hey

As doughemi said global fields are User and Session specific. I.e. the values hold for this user while they are logged into the system in the current session - when they log out all those values are cleared out (when accessed through FMS).

I'm guessing the reason that you are still having problems, based on doughemi's advice, is that you are most likely still treating your fields like globals despite the fact that you have turned global storage off....

Your country field needs to be a non-global, there needs to be only 1 record in this table and to amend the value of the non global field you will need to navigate the user to the table in which it resides, whereas globals can be set from anywhere in the system.

Hope this helps!

Vicky

Share this post


Link to post
Share on other sites

It is not working. Please suggest me some another way.

It would be helpful to know specifically what is not working.

Do you have a TO of Globals related to the table occurrence used by your layout with a Cartesian (x) relationship?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.