Jump to content

Cannot find the object


This topic is 2577 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a cell named "BurnDVD_the_list" in a table named "@Preferences"

 

SCRIPT

Set Variable [$$the_list]; Value:"01020804"]

Go to Layout ["@Preferences" (Preferences)]

Replace Field Contents [No dialog; Preferences::BurnDVD_the_list"; $$the_list]

Perform AppleScript ["display dialog"bSET"  "set FMPrec to cell "BurnDVD_the_list" of current record  "display dialog"bSET"....]

 

RESULT

  • the variable $$the_list is set to "01020804"
  • the field BurnDVD_the_list is set to "01020804"
  • a dialog box appear showing "bSET"
  • en error cannot find the object is displayed, I click OK an unknown error : -1728 is displayed
  • the dialog box "aSET" is never displayed

The error is then at the command line "set FMPrec to cell "BurnDVD_the_list" of current record

 

Could someone tell me what am I getting this error?

Why I cannot get the value of a cell within a "Perform AppleScript" ?

 

 

Many thanks!

Daniel

 

 

Link to comment
Share on other sites

Thanks Comment, problem solved. I had two layouts with almost the same name (do not know why).

I change the layout name and everything is now working.

With regards!

Daniel

Link to comment
Share on other sites

This topic is 2577 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By steveald
      XPOST
      Our company is switching to VPN for remote users to to connect to our FMS-hosted databases. So I want to incorporate connecting to VPN into our already established procedure for accessing those databases via a FileMaker script.
      Our VPN connection is up and running. And I found an AppleScript that works well making and continually checking the VPN connection. But I don't know enough about AppleScripts and how they apply to FileMaker scripts to make it work. From what I could find on the subject, I need to modify the AppleScript steps to work in FileMaker; such as adding a \ in front of each double-quote. But, apparently that's not all.
      Here is the raw AppleScript code:
       
      on idle
      tell application "System Events"
      tell current location of network preferences
      set myVPN to the service "VPN NAME"
      if myVPN is not null then
      if current configuration of myVPN is not connected then
      connect myVPN
      end if
      end if
      end tell
      return 60
      end tell
      end idle
       
      And here's what I did: I created a new FileMaker script and added one step - Perform AppleScript. In the step options, I selected Native AppleScript and entered the above code. (Using Calculated AppleScript didn't appear to be the right choice for this method.) I saved the script and tried running it, but nothing happens. No errors, nothing. From what I was able to find on the subject, I assumed the problem lies with how the AppleScript text is formatted in the script description. But, nothing I tried worked. Can someone show me what needs to be done with the above AppleScript to make it work in a FileMaker script?
      One major issue may be the restriction: "Indenting of repeat loops and conditional statements is not supported." This may limit me to stripping the AppleScript down to just the connect VPN portion. But, I really liked what the AppleScript offered in the way of checking regularly to make sure the connection is still active and to re-connect if it isn't. So, if there is another way to do this, I'm all ears.
      Finally, just in case there is a better method for all of this that I am just not aware of, here is the "big picture": My remote users each have a small database file they open every day to access our FMS Server-hosted databases. The file contains one button which activates a script that opens the required databases. Switching to VPN simply meant setting up the VPN connection on each computer and changing the External Data Sources in the local database. What I hoped to do is to modify the script so that it first makes the VPN connection and then, once that's completed, opens the databases. An alternative process might be to create a separate script to make the VPN connection and that script could be set up as a Script Trigger which activates when FileMaker is first started up or the file is first opened.
      Just to complicate matters, I also need a similar FileMaker script that will connect to VPN on a Windows 8 machine - which, of course, precludes using AppleScript.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.