Jump to content

activating Java 1.8 on Mac for SM


 Share

This topic is 2815 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi to all Pro´s here!

 

We have developed a solution to use ScriptMaster to execute Java Code. This will work well on the Windows side but on Mac OS X it (ScriptMaster) says that Java 1.6 is installed. That is bad, we need Java 1.7 or 1.8. In the Terminal it says 1.8 (or list it as 1.8), but in ScriptMaster it says Version 1.6 is used (so we can´t use Java on Mac).

 

Now I´ve seen (sun website) that Apple does not support 1.7, but is there a way to activate 1.8 (or at least 1.7) ?

 

I´ve added 3 Screenshots to clear out what i mean.

 

Sorry for my formulation, i´m the carrier of the information :-)  I´m not the Java Coder.

I hope there is a solution, otherwise all the development is for the trash.

 

need help

best wishes, Hans_007

---

Mac: Yosemite, OSX 10.10;

SM Version: 4.206 (testing Version 3.1 same)

Filemaker Adv. 13

Terminal_SM.zip

Link to comment
Share on other sites

Hello,

 

All of our plugins require that there is a 32-bit Java Runtime Environment installed in order to operate. You can have more than one JRE installed on the system and our plugin will use the one that it needs. This is why you are seeing that Scriptmaster is using Java 1.6 but terminal lists Java 1.8 .

Link to comment
Share on other sites

Do you have any kind of road map for this issue, given that it is now also harder to find 32bit 1.6 for Windows too??

And there are several notable places where MajorMinor errors are because we can't access some of the newer classes or methods in 1.7

 

It is a support issue in convincing people that they should install an old version at times.

Link to comment
Share on other sites

 The reason we use 1.6 for Mac OSX is the versions of Java provided by Oracle do not have the necessary Java Virtual Machine (JVM) capabilities that we require for the plugins to communicate with FileMaker. Also, you do not have to have 1.6 for Windows. You can use 1.7 or 1.8 in a Windows environment as long as it is 32-bit . 

Link to comment
Share on other sites

This topic is 2815 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.