Jump to content

Data Not Read Correctly with ODBC


This topic is 3045 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi,

New to Filemaker Pro and ODBC. I am trying to set up a parts database/library for my CAD software, Altium. Altium can read the data through ODBC. I have created a small test database to get started. I have the xDBC driver installed and I have set up a System DSN in the Windows Data Sources (ODBC) dialog. Altium is able to connect to my database, view the table, and read the column names.

When it reads the data in each cell, however, it just displays (MEMO) for each cell. In FileMaker, these cells are standard text cells. If I choose a number cell, date cell, time cell, etc., then these work perfectly and I can see them in Altium. Only the text fields seem to have a problem.

I found a site that mentioned that the memo field (or multi-line) is the default for FileMaker, and that "You have to take special actions to keep a field at one line" (http://www.tek-tips.com/viewthread.cfm?qid=1231827). Could this be the problem? Is Altium expecting a simple, one-line text field and Filemaker is giving it a multi-line field?

I have tried importing the database into an Excel table through ODBC, and that worked with no problems. But maybe excel can deal with the Memo fields and Altium can't?

Edited by dcoryh192
fixed hyperlink
Link to comment
Share on other sites

  • 3 weeks later...

This topic is 3045 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.