Jump to content

Network issue FMP13A El Capitan


fed

This topic is 2640 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have been having some network issues using FileMaker Pro 13 advanced on OS X. I had a similar issue with Yosemite, but it seems to be worse with El Capitan.

I am using a shared folder on another OS X computer  in order to transfer information between the two computers. The file in question is a FileMaker Pro 13 database, which I write to and delete. At times, the network seems to fail, and FileMaker Pro 13 advanced seems to crash.  I have run all the tests on the database, and everything seems just fine. Otherwise the database runs very smoothly. If I do not  use the database in the shared folder, everything works just fine. 

 Any ideas what could be wrong? Any help would be greatly appreciated. 

Link to comment
Share on other sites

FileMaker Pro 13 is not certified to run on El Capitan. The problems you report are expected ones.

Please see http://thefmkb.com/15186.

Also, if I understand correctly your description of how you are accessing the FileMaker Pro file, that is not really a good idea.

I would recommend you look into how you are supposed to share a FileMaker Pro database across a network.

Steven

Link to comment
Share on other sites

  • Newbies

I've had problems with using remote host on another mac. The first would affect any version of FMPro, is when the host mac goes into sleep mode and disconnects the network causing the database to close on the remote mac. The other I've run into is using a wireless connection with a laptop to connect to the host mac would sometimes drop the connection because of wireless interference on the same channel. Changing the wireless channel on the router fixed the network dropping issue.

Just my 2 cents.

Glenn

Link to comment
Share on other sites

3 hours ago, Meltonio said:

I've had problems with using remote host on another mac. The first would affect any version of FMPro, is when the host mac goes into sleep mode and disconnects the network causing the database to close on the remote mac. The other I've run into is using a wireless connection with a laptop to connect to the host mac would sometimes drop the connection because of wireless interference on the same channel. Changing the wireless channel on the router fixed the network dropping issue.

Just my 2 cents.

Glenn

These are exactly the situations I am referring to!  Thanks for narrowing it down. I really don't think the OSX version has anything to do with it.  I will disengage sleep mode on he host, and not use wifi and see if things are cured. 

Thanks!

3 hours ago, Steven H. Blackwell said:

Now you know why we recommend FileMaker Server. And why the OS level settings are just as important as the FileMaker Server settings.

 

Steven

Sorry, but what do you mean by OS level settings?

Link to comment
Share on other sites

So, after some troubleshooting, I found that the problem was that  the computer with the shared folder  was going to  screen saver, and that was interfering with the connectivity, resulting in a crash of FileMaker Pro when I tried to access a link to the table. Thank you very much for pointing me in the right direction, Meltonio. 

Now I am wondering if there is a way to check for connectivity, either through Filemaker or OSX directly, before trying to access the table, thus avoiding the crass. 

Again, any help would be much appreciated. 

Link to comment
Share on other sites

No, checking for connectivity is a step too late.  When you set up a server (or FMP as a host - which is a lot less ideal) then the idea is to follow all server best practices and those include disable power saving functions, screensavers, etc...

Link to comment
Share on other sites

  • 1 year later...

Question about Wim Decorte's note to "disable power saving functions, screensavers, etc.". 

We have FMS15 on an iMac. Can I at least put the display to sleep (without a screensaver)? I don't like the idea of the display being brilliantly lit all the time... I'm talking about setting a hot corner to "Put Display To Sleep" so I can blank the screen when I walk away. (I used to have it set to a screen saver, but I can understand why that may not be desirable from a performance point of view.)

Thanks.

Link to comment
Share on other sites

This topic is 2640 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.