Jump to content

Formatting Bar Grayed Out


This topic is 2769 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi,

Any assistance here I would be grateful ...

I can not get my formatting bar to "Un-Gray" itself when my users log in and the custom menu loads. ???

I've set my "Formatting Bar ( ON )" in my script ?? And when I'm logged in as "Full Access" I have no problems ?? The formatting bar is available clicking into the field.

I've attached my customer menu, where I've even added the "Formatting Bar" but all it does is "Hides and Un-Hides" ... but the "Formatting Bar" remains grayed out, unavailable.

I can not allow full access with users and I must have access to the "Formatting Bar" ?? when my custom menu set loads.  What is going on ??

Thank you.

 

Link to comment
Share on other sites

"The formatting bar is available clicking into the field"

"The formatting bar is available (when) clicking into the field" ?

So there is no problem?

Users have edit privileges for the field(s) involved?

Link to comment
Share on other sites

BruceR,

 

"The formatting bar is available clicking into the field" - No

"The formatting bar is available (when) clicking into the field" ?  - No

So there is no problem? - I don't understand this one ?

Users have edit privileges for the field(s) involved? - I don't understand this one either ?

 

Link to comment
Share on other sites

Lee,

The first two I answered with "- No".

the last two, I don't understand.

I've attached the "Security" pane and the "Custom" menu pane ... please see attached.

In the custom pane I even tried added the "Formatting Bar" but that did absolutely nothing other than true "On or Off" the formatting bar.

Any assistance here would be grateful.

Thank you

Screen Shot 2016-09-21 at 10.16.49 AM.png

Screen Shot 2016-09-21 at 12.07.26 AM.png

Link to comment
Share on other sites

How can you say "NO" to your own statement? I'm just quoting you. 

Quote

"The formatting bar is available clicking into the field."

What do you mean by saying this?

Regarding users having edit privileges:

The formatting bar should be grayed out if the user is not in a field.

If the user cannot format the field, because it is a calc field or because they do not have edit privileges, the formatting bar SHOULD be grayed out.

Link to comment
Share on other sites

BruceR.

Filemaker is causing this confusion as explained briefly in a "Filemaker Hack" post.

https://filemakerhacks.com/2014/06/14/showhide-formatting-bar/

I can turn on  and turn off the "Formatting Bar" meaning I can see it or not see it via "a" script step or in my custom menu but the formatting bar remains grayed out when I click into a "Text" fields.  This text field is just a plain ordinary text field.

The formatting bar becomes available; meaning selectable when I've clicked into this text field when I log in with "Full Access", but when my user logs in, and the "Custom" menu loads it would seem that the "Custom" menu is preventing the "Formatting Bar", the formatting bar remains grayed out when the user clicks into this text field.

I don't know how else to ask how to solve this issue ...

Thank you.

Edited by Mr. Ignoramus
Link to comment
Share on other sites

The FileMakerHacks article does a good job of explaining the problem.

Note that the article tells you directly how to solve the problem.

Did you follow those instructions?

It sounds like you did not; you're still trying to include formatting bar in the menu.

It **IS** a bug; but apparently you can't do that.

Link to comment
Share on other sites

BruceR,

Yes I did, however I am on a hosted solution and I saw that Frank said that the example file must be on a local file, so when you say "It is a bug" you are saying that the "Formatting Bar" is not allowed on a hosted solution when using a custom menu ??

 

Link to comment
Share on other sites

Here is the answer for those who are interested.

philmodjunk suggested that I post on "FM Problem / Trouble Forum" which I did and Fred(CH) responded with the following solution.

Apparently I failed to "Add" the "Format" to my custom menu set. When the "Format" was added to my custom menu set the "Formatting Bar" became active when the user clicked into the "Text" fields.

Please see attached pdf.

Thank you philmodjunk for your suggestion.  And a special thanks to Fred(CH) for your insight.

 

 

Format.pdf

Link to comment
Share on other sites

This topic is 2769 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.