Jump to content
Lewis Stairs

Upgrading from v2 to 3

Recommended Posts

Hi,

I have purchased the licence to upgrade from MIrrorSync 2 to MirrorSync 3 and have begun to install it. The configuration tool explained that the MirrorSync table and scripts were obselete and I needed to copy in the new ones, however, upon copying the scripts I get the attached error message. 

Copying the table and layout works fine, but not the scripts. 

It also worries me slightly that the application window title shows as '360Works MirrorSync Configuration: null' - is this a concern? 

I have tried re-downloading the configuration client, with no luck as yet. 

Any guidance would be greatly appreciated

Lewis

Error.PNG

Hello again,

I have fixed this issue by uninstalling MirrorSync and re-installing v3

Sorry for all the fuss :)

Share this post


Link to post
Share on other sites

Hi Lewis,

Glad you got figured out and thanks for updating the thread with how you fixed it!

Of note, the title at the top of the window having the "null" value is expected behavior for a new configuration. That null value will change to the name of the configuration once you complete it and go back and edit it.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you for coming back to me, Ryan. 

As a secondary issue to this, I am struggling with getting the customisation script to work as expected. I have pasted in the appropriate script steps from before the upgrade (not all of them, just the ones for the find changes). I have also updated the spoke database customisation script to set the $$MIRRORSYNC_USERTOKEN correctly, but the sync does not seem to be taking any notice of this, it just syncs all records at the hub.

I have debugged the customisation script on the Hub and it works correctly when the $$MIRRORSYNC_USERTOKEN is set. Is there any way for me to debug whether the MIrrorSync script is calling the customisation script on the Hub correctly, and work out where this process could be going wrong?

Thank you for your help so far

Lewis

 

Share this post


Link to post
Share on other sites

Answered via our support ticket, but for anybody else running into the same issue, the problem is probably that you're using JDBC (the default) instead of XML. JDBC is faster and generally more efficient, but to filter records with JDBC, you do it with a custom SQL qualifier in the same screen as the primary key pulldown menus. The MirrorSync customization script is totally ignored on the server when using JDBC (because JDBC cannot call scripts).

  • Like 1

Share this post


Link to post
Share on other sites

Thanks Jesse,

Can confirm - that was the issue and all is working OK now. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Agentshevy
      Problem Upgrading to Filemaker Server 16.. We want to Upgrade from FMS 15 to 16, and each time I get this error during deployment.
      However, when I revert back to fms15, everything goes fine.. I have tried Clean Installation, yet same result..
      Can someone put me through.. We are using Windows 7 professional as our system unit

    • By ScottVan
      Is there any special procedure to upgrade from 2.6 to 4.0? Previous upgrades have been essentially flawless - however I suspect there might be a hitch going forward so much? 
      Thnx
      Scott
    • By eqitec
      I want to take advantage of the FM16 BOGO offer by 12/20/17. I am presently using FM13 Adv.
      Are there any special concerns I should watch out for in going from FM13 Adv to FM16 Adv?
      Thanks.
    • By Martin Taylor
      Hi all experts (hopefully), I have just upgraded from FMS12 to FMS16. On the FMS12 server we are running a php solution. I have installed 16 onto a new server, uploaded all the databases (all successfully running) and have copied the php website to the new location on the 16 server. I can see the website from home (so I know the website is in the right place and the DNS s working) BUT I can't seem to connect to the database successfully. Any help would be much appreciated. Thanks in advance. 
      Oh, and it is accessed with https
    • By charlitoA
      Hi all
       
      I recently bought a licence of 360Works Email 2, working great, but I will need to upgrade to Workgroup Licence, I thought that only when sending an email and only then where using the licence, but apparently not and I need to upgrade
      Do anybody know if I get a disscount for having already the single user licence? Or do I have to buy from scratch? It's the same file or it's diferent?
      Kind Regards
      Happy Programming
×

Important Information

By using this site, you agree to our Terms of Use.