Jump to content
JeromeMaeckelbergh

The file "xxx.fmp12" could not be opened. (Not Found)

Recommended Posts

I am working already a few months on my file "DTW-new.fmp12" via the FM-server 15 on my MacBook Pro without problem and suddenly today this file can't be found anymore, although it is still on the server. But it shows that the status is "Closed", so I probably should change this to "Normal" or something else. Sorry for my ignorance, but I can't figure out how to do this. I tried with "open" and "open all", but this doesn't help me.58cabf5727be3_ScreenShot2017-03-16at16_36_27.thumb.png.e6b98275ccbb30e364e3f419234fef57.png

Thanks for any help,

Jerome

Screen Shot 2017-03-16 at 16.09.09.png

Share this post


Link to post
Share on other sites

"Open" is what you're looking for, which for some reason doesn't work for you, obviously. What does the log say ? ("Log Viewer" in the left pane)

Share this post


Link to post
Share on other sites

Dear Lem, the log says:

Type: Error

Event: 1017

Description: SECURITY: Database “DTW-new” cannot be opened because it is insecure. Require Password-Protected Databases is enabled.

and shows that each time I tried to open it. I didn't enabled any password on this file, so I don't understand. I did also a "Verify All" but in the Log Viewer I see only a "Performing consistency check of database "FMServer_Sample"", nothing about my file.

Best regards,
Jerome

Share this post


Link to post
Share on other sites

That's the problem : your filemaker server is set to only open files where [fullaccess] accounts are password protected , but from what you say, none of the accounts has a password, so obviously the [fullaccess] doesn't have one.

In order for your file to open, you'll have to set a password for [fullaccess] accounts. Which is more than  highly recommended anyway.

Other obvious security flaws that prevent a file to be opened : "auto log in with account :" set with a [fullaccess] account, or a Guest account with [fullaccess] privilege.

Share this post


Link to post
Share on other sites

And therefore FileMaker Server will not allow it to be opened.

FileMaker Server 15 does not open no-password files.

Share this post


Link to post
Share on other sites

So my problem stays: how come that I was working with FileMaker Server 15 without any problem on this file for months and just from today I can't anymore? And what will be your advice to insert as yet a password not being able to open the file? Is it possible that as FMServer administrator I can export that file in some way and still do so?

Share this post


Link to post
Share on other sites

Maybe the "Require Password-Protected Databases" setting was not enabled before ? Anyway...

You can "Download Database" from the same menu (in your first screenshot), then delete the db from server (trash icon on the top-right)

Open the file locally with Filemaker Pro, set a password, then upload it again to FMS using "Share / Upload to server" in filemaker pro.

Share this post


Link to post
Share on other sites

Thanks for your suggestion already. I copied the file to my desktop, but now it seems, although I have full access to all developer's features, I can't add a password to the file. I receive the message "To manage the security of this file, enter an account with Full Access privileges." Whatever I enter in "Account name" and "Password" fields, I can't, what is logical, as I never set this file like that. My guess is that I have to make a new file, this time password protected, and then importing one for one the necessary tables with their fields, layouts, scripts, relationships, etc. and then the content, or do you have any idea that is less labour consuming?

Best regards,

Jerome

p.s. Still amazed that what worked well for so long, suddenly the FMServer changed mood about me having access to the file. The date that you see on the screen shot of the file concerns the content of the dictionary and has nothing to do with the FileMaker version I work with, namely FM pro 15 Advanced 15.0.3.305 and FileMaker Server 15.0.3.308.

58cb029f7d16c_ScreenShot2017-03-16at21_23_37.thumb.png.a79bd1ab8a4075581172bf5e84159375.png

 

Edited by JeromeMaeckelbergh

Share this post


Link to post
Share on other sites

For the moment, your [fullaccess] account has no password, so you may access security by just entering your account name and leaving the password blank.

Then you'll set a password, and when you validate the settings, it will prompt you with the same dialog again, which you will then fill with your brand new password.

Share this post


Link to post
Share on other sites
13 hours ago, JeromeMaeckelbergh said:

 

p.s. Still amazed that what worked well for so long, suddenly the FMServer changed mood about me having access to the file.

 

 

As long as you think that you will be no closer to solving this.  FMS does not change the permissions on a file or change anything at all in the file.  It just does not.  So something else changed:

- either you or someone else with full access changed the security settings of the file

- either you or someone else with FMS admin console access changed the setting to allow or disallow files with no pw to be hosted

- or the deployment is flawed, doesn't follow best practices and the file got damaged in the process

Share this post


Link to post
Share on other sites

Probably it is your third option, as I am working with a FileMaker Server license from a FileMaker Developer Subscription on my MacBook Pro on which I am the only person accessing it. When it is due to a damage of the file, it is a very specific damage, as apart from changing the security access to the copied file on my desktop, I can manage anything else that I need: Database, Scripts, Layouts, etcetera so full access with the exception of Security.

Also my thanks to Lem Alpha, but still whatever I enter as account name (even the classic "admin"), leaving the password blank, I get the same result: "The account name and password you entered does not match those for any FileMaker account.". Normally, as I even didn't specified any account to the file, I should leave both fields blanc but also this doesn't work.

So I am afraid that I will have to go for the labour intensive option to copy everything to a new FileMaker file before putting it back on my FMServer.

Best regards,

Jerome

Edited by JeromeMaeckelbergh

Share this post


Link to post
Share on other sites

Do you have access to an older version of filemaker pro ? If you have access to a v13, you can access "manage security" without the first dialog.

  • Like 1

Share this post


Link to post
Share on other sites

Dear Lem Alpha, Wim Decorte and BruceR,

Thank you all for saving me much time, in particular to Lem Alpha. I tried first with my still installed FM v14 without result, but indeed with reinstalling my FM v13 I could do the trick. Checked it out with my FM v15 and it works.

Best regards,

Jerome

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.