Jump to content
SarahS

Cannot Launch MirrorSync after Installing SSL Certificate

Recommended Posts

I am running MirrorSync 3 on a FMS 14 machine (OS 10.9.5) and recently switched from using the self-signed certificate to a SSL certificate issued by a certificate authority supported by FileMaker.  I was able to successfully install the SSL certificate.  I didn't think I needed to make any changes in the MirrorSync configuration when I switched the SSL certificate since the configuration was already setup for SSL.

Another major server change I made prior to installing the SSL certificate was I uninstalled FMS 14.0.1 & reinstalled 14.0.4 to enable communication with FM 16 clients.  But according to the documentation topic "What if I need to redeploy FileMaker Server?", I didn't think there was action I needed to take with MirrorSync.

My user in Mexico just notified me today that she cannot sync and I am unable to open MirrorSync on the server.  Obviously MirrorSync was affected by one of the changes I made.  I can't find an error log from today on the server from when the device tried to sync.  I did have the device user try to use the Report Bug button, but she said it also gave her an error message.  What do I need to do to recover & get back up & synchronizing?  I do have a full server drive backup (made after stopping all FileMaker processes, and excluding the Data folder!) from prior to doing the uninstall and reinstall of FMS 14.0.1/14.0.4.

When I do https://yourservername.com/MirrorSync, I get the "Object Not Found!" Error 404 page...

I have a screenshot of the error dialog she is seeing on her device and can send that if you want.

Thank you for your guidance!

Share this post


Link to post
Share on other sites

For anyone that may read this thread in the future, Tsiry from 360 Works provided great support and helped me get it resolved.

I tried stopping/starting the 360Works application server using 360Works Admin.jar at /Library/360Works/ but that didn't help, but it did give me access to the MirrorSync page to allow me to submit a bug report including the day's server log.

I then reinstalled MirrorSync 3.17 and that resolved it!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×

Important Information

By using this site, you agree to our Terms of Use.