Jump to content

TimeTrackingMod EditSequence


Recommended Posts

I'm working on scripting add and modify TimeTracking for a client.  The issue is that I am getting a lot of errors that look like:

CODE: 3200
SEVERITY: Error
MESSAGE: The provided edit sequence "1607267988" is out-of-date.

The issue is that the edit sequence is/should be correct.  When modifying a record I run a script that gets the current Edit sequence for the record then run the modification/update.

This seems to be an issue with TimeTracking.  I use the same setup for other areas including Clients and Vendors.  With the other areas,  this appears to work 100% of the time.

I have a section of the script that actually pulls into FileMaker all of the current TimeSheets.  When I do this, the edit sequence in the downloaded record matches the value in the error code.

Any suggestions on what I can do to resolve this?

Thanks

Bruce

 

 

Link to post
Share on other sites

Well this is resolved.  Issue was incorrect field name in PCQB_RqAddFieldWithValue() function.  When the Script to get the edit sequence was first written,  all of the QuickBooks tables used the field ListID.  TimeSheetQuery uses TxnID.

So the error and result were misleading.  Instead of throwing an error because I was using the wrong field name it returned an edit sequence for the wrong record. 

After much hair loss,  I finally saw that I was using the wrong field.  Updated the script to dynamicly select the correct QuickBooks field and now it works 100% of the time.

Hope this misadventure is helpful.

Bruce

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.