Jump to content

I'm REALLY Freakin out [email protected]


This topic is 6607 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I posted this about 2 weeks ago, but I really want people to see it again, and maybe SOMEONE can help me!

The original post is "I'm Desperate" (2/5/05).

The problem first appeared for me when I was testing the import for my new release of my FM6 runtime application. In the main (HERD) database, I got the message: "Sorry, FileMaker is unable to read the disk this file is on." It would not allow me to continue and it corrupted the new file (and I was not able to recover it.)

Please note, this is my 3rd release of the software and never had this problem before.

After playing around, I thought maybe it had to do with the size of the file (approx 2.5MB with no records). I created another database with field definitions only (no layouts or relationaships) and changed to import into that file and then import one record at a time into the HERD db.

OK, that seemed to work. I have not had a recurrence of the problem...


(This gets reaslly scary now!)

I had an error in the current version of my FINANCIAL database. Since I have clients using that for their taxes, and could not wait for the new version, I sent out a fix if requested. This is a small file (only about 700kb.)

I just got an email from one of my clients that they got this same error on the Financial import...!!!!!!!

The import works as follows:

I have the user rename the Financial file to Financial_Old, and copy the new Financial file into the solutions folder. When the new Financial file is first opened, it imports the records from Financial_Old.

One other note: I had to replace the client's file 3 times (my error for not testing it thoroughly). The first 2 times, the import worked just fine. (I ran it about 4 times and did not get the error.)

So, I apologize for the novel, but I'm going bonkers. Any IDEAS??


Link to comment
Share on other sites

Are the HERD and FINANCIAL files in the same database? If not, do you have a really good anti-virus program running?

This is probably not relevant but .... I have had diabolical problems with XP corrupting CD-ROMs.

Third idea - a LARGE bottle of bourbon.

I had a similar message when I left a CD copy in the drive while playing around with the HDD copy. Can't remember the details because it was due to stupid carelessness on my part. (I'm sure this is not your problem. wink.gif )

Link to comment
Share on other sites

There are 27 database files bound together in my runtime solution. Sorry, but I don't see any security tab under properties for the file! I tried again with the same file and no problem. I have asked my client to try again after a fresh re-boot of her computer. I'm waiting for her results.

My main concern is figuring out what this really means and how I can fix it, so it won't be an issue when I release the next upgrade (due to be released in about 6 weeks!)


Link to comment
Share on other sites

"Sorry, FileMaker is unable to read the disk this file is on."

Have you considered that the computer's hard disk is dying?

Or perhaps the files are on a shared network volume, which is really not a good idea either.

Link to comment
Share on other sites

Ellen, Are you sure the file wasn't corrupt before you tried the import? Maybe FMP couldn't read the file and decided it was a disk error.

I've been racking my brains to try to remember why I got this same message. No luck. However, I do know that it was always due to something other than hardware problems.

Do you know which file is giving the message? Is it the new one or the old one? Is it possible that your import statement is broken and FMP is looking in some non-existent place for the old file?

I am REALLY keen to have your problem solved because I use the same technique for distributing updates and I'm terrified!

Link to comment
Share on other sites

  • 2 weeks later...

This topic is 6607 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.