Jump to content

ODBC Data Client - cannot find in Data Sources


This topic is 6612 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Under Administrative Tools on my computer there are a number of default Data Source files installed with Windows XP(SP1). However, the only ODBC file present is:

Microsoft ODBC for Oracle.

Version 2.575.1022.0


Date 20/02/2003

So to be able connect to FileMaker using an ODBC datasource at some time in the future I thought I would download the relevant file from the Filemaker website which can be found at


I downloaded the file for Windows, clicked on Setup and everything installed it appeared with no problems. Went to C:ProgramsDataDirect and all seemed OK.

So I selected the ODBC Administrator and fired that up which in turn opened up the ODBC Data Source Administrator in Administrative Tools.

What follows is what I had to do next according to instructions in the help files:

"Click the User DSN tab or the System DSN tab to list user or system data sources, respectively.

To configure a new data source, click the Add button. A list of installed drivers appears. Select DataDirect 32-BIT SequeLink 5.4; then, click Finish."

I became confused about the whole thing because the "DataDirect 32-BIT SequeLink 5.4" did not appear in the list of available drivers. Also I was expecting some reference to ODBC to be in the file name like the Oracle one. Please don't ask me why I want this anyway, because as an absolute evaluation beginner - I would not be able to answer that question!!! But I suppose somewhere down the road it will become clear....! I just thought I would get it sorted now - one less thing to think about.

Is there something else I have to do to achieve the correct situation which as someone just starting out, I am overlooking

Thanks for assisting me.


Link to comment
Share on other sites

Still dazed and confused...OK, do this: Control Panel | Administrative Tools | Data Sources (ODBC) | Driver tab--check that DataDirect is there | System DSN tab--add your tables/files here (data source name, usually with an _dsn ending; SequeLink Server Host = localhost; SequeLink Server Port = 2399 ; Server Data Source (your FM file, make sure you have ODBC permissions set)) | Test

Link to comment
Share on other sites

Transpower, that is what I have been saying all along - on the Driver Tab - DataDirect is not there - that is why I did the posting.

I am confused BECAUSE it is not there. It is the "why it is not there" that I am trying to establish.

That is why I wrote in my first posting the following, I tried to be as clear as I could:

"because the "DataDirect 32-BIT SequeLink 5.4" did NOT appear in the list of available drivers. "

So perhaps you can appreciate my dilemma now. Thank you however for trying to assist.


Link to comment
Share on other sites

When you select any of the DSN tabs and click Add, you should see DataDirect 32-Bit SequeLink 5.4 as an option in the selection list. Do you have full admin right on your computer, and/or do you have virus protection turned on on this computer? I have seen these two issues cause problems with the driver install.

Link to comment
Share on other sites

Thanks Walter B. I do have full admin right on my computer - I am the only one using it. However, I also do have AVG Antivirus protection turned on in answer to your posting.

Currently as I said in my last posting - it is not available in the Driver Tab.

So maybe you are on the right track to solving this. I will leave here and turn that off temporarily and get back to you and let you know what if anything happened as a result.


Link to comment
Share on other sites

WalterB. This is what I did.

Turned off my Antivirus program. Turned off my Firewall program.

Then I uninstalled the downloaded driver file that I had I got from Filemaker.

Following this I installed the driver again.

Tested to see if it was present and it was still not in the Driver Tab list of available drivers. Just the same group of files as before.

Next I switched off my computer and then switched on again. Situation was exactly the same.

Can you tell me something please WalterB. This installing business - when I pressed setup to install the DataDirect driver, does it automatically put it into that list or is there something else I have to do to get it into that list.

Grateful to know that, because up to now I have just assumed that it would appear there as a direct result of the installation. Many thanks for your assistance.


Link to comment
Share on other sites

Thanks for your guidance on that. However, at the present time I only have the downloaded evaluation file of Filemaker Pro 7 but I will bear that in mind when I come to purchase Developer 7 which I expect to do so shortly. I have 11 days left for evaluation.

However, as I wrote in my posting to WalterB I am not clear whether this driver installation routine that I went through is designed to automatically place the driver in the Driver Tab list, or alternatively do I have to do something else to get it there in the first place.


Link to comment
Share on other sites

The driver SHOULD appear after installation with out doing anything else, but there's a bug in the installation of the DataDirect SequeLink driver that may cause the symptoms you're describing.

Sometimes a bogus (default) registry entry is created under


The entry is labeled (Default), but it is not a real default key. Instead of showing a value of "(Value not set)" as is normal for a default key, it shows a blank value.

To fix:

Close the ODBC dialog.

Run RegEdit.

Locate this key:


Look for the bogus (Default) entry.

Delete it.

When you do, a new entry will be created automatically. Now the ODBC drivers should appear in the ODBC manager as expected.

Note: You might see two separate (Default) entries. Delete the one that doesn't say "(Value not set)".

As always when editing the registry, you should make a backup first, in case

something goes wrong.

Link to comment
Share on other sites


Well done!! What you posted was the total solution to my problem.

Thanks - it has now APPEARED in the Drivers Tab.

However, as I indicated in an earlier posting - I haven't a clue what it is used for at the present time. All I did was give it a name and left it at that for the moment. Transpower posting has given me a lot of detail which I have printed off for future reference.

But for the present, what it allows me to do and why I need it is for another day. In the meantime very grateful to you and all the other contributions made regarding my posting.

Hope it helps someone else that perhaps will come up against this DISAPPEARING data source in the Drivers Tab. Whilst I was in the Registry area I did see that it was present in the list shown there, and in fact I did have 2 Default entries showing blank values. As soon as I deleted the first one, another Default appeared showing a value of "(Value not set)". Then I deleted the second one and that was it.

Kind regards.

David smile.gif

Link to comment
Share on other sites

Glad to hear you got it working. The interesting thing about this bug is that it can prevent other ODBC drivers from appearing as well. In fact, I first discovered the bug when I had trouble installing the ODBC drivers for PostGreSQL. It was a real hair-puller, but I finally figured out what was going on.

Aside from this weird installation bug, the FM7 ODBC driver works quite well. This is a refreshing change from previous FileMaker ODBC drivers, which pretty much sucked. smile.gif

As for how you can use it, one common use is to automate the process of importing data from FileMaker directly into another application, such as Access or Excel. Another use I've found for it is to make duplicating complext tables a little easier. That helps offset the fact that you can't duplicate a table directly in FM7.

Link to comment
Share on other sites

This topic is 6612 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.