Jump to content

Right to left characters

This topic is 6591 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

First time post, I checked for this everywhere and I couldn't find an answer.


I created a database for a friend with fields to type characters in right to left. (for example: hebrew) 2 problems:

1- no matter what font I set the field to type in, it automatically switches to arial.

2- it types out fine, however when I need to edit the field everything is backwards. Meaning when I press backspace it backspaces from the other side as if it's left to right.

If anyone has any help please let me know.

[email protected]

Link to comment
Share on other sites

In the Define Database window, select your field and click options... Under the Storage tab, select the language for sorting. Hopefully there is a Hebrew option in your version. Once you change that, you should be able to change the font for the field.

As to your second question, I haven't encountered this, but, maybe the sort language selection will correct this too.

Link to comment
Share on other sites

If there is another language which runs right to left text, you could try that one. The fonts fall into different categories. If you have the field set to Roman encoding, it will only allow you to select a Roman type font such as Arial.

There is also another thing you could look at: Open the Filemaker preferences and go to the fonts tab. There are some options there which you could play with.

It is possible that you will need to buy a special Hebrew version of Filemaker (if there is one).

Link to comment
Share on other sites

Sadly, FMP has no support for single-byte RTL languages. You can (and probably should) select Unicode in the field definitions, but that only affects sorting and indexing.

I suspect that when typing in Hebrew, the OS forces the input to Unicode. As a result, FMP will not let you change the font to a non-Unicode font, or to a Unicode font that lacks the Hebrew characters set. But that is only a guess.

Link to comment
Share on other sites

This topic is 6591 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.