Jump to content

Delete Record is deleting ALL records


This topic is 5720 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hello All,

I could not find a forum that sounded like an exact fit for this. So I picked what seemed like the closest option.

I am experiencing something strange.

When I select "Delete Record" from the "Records" menu, ALL of my records are being deleted. It does not matter if the records are found or not - they all get deleted.

Anyone heard of this or know what might be causing it?

I am not deleting a record that is in a different table. I am not deleting via portal or a relationship of any kind.

I am not in a list view. I am simply viewing a single record. It contains a tabbed interface and some of those tabs have a portal in them. But I don't see how any of that would effect this.

I am frankly stumped.

I have sent this off to Filemaker tech support, but thought I would see what the pros here have to say.

Maybe I am just missing something obvious and its pilot error.

My next step is to move the solution over to the windows side and see if the same thing keeps happening.

By the way, running the latest 8.0v2 (happenning on v1 as well tho)

Thanks,

R

UPDATE:

While in list view, I am able to delete a single record as normal. What could POSSIBLY be something going on with a layout that would cause this?

FURTHER UPDATE:

Ok. I have copied it to windows. With 8.0v1 installed, no matter what type of layout I am in, all records get deleted when I do a Delete Record.

Updating to 8.0v2 did not fix it.

So as it stands now, on the mac I can delete single records when in a list view layout only. On the windows side, I cannot delete a single record at all.

A CHANGE IN ACTIVITY:

Now on the mac side all records are being deleted when in a list layout as well. This is just too bizarre.

I went ahead and opened the file in FMP 7 Developer and the same error is occuring.

I tried recovering the file, this did not change the problem.

Link to comment
Share on other sites

Check all the relationships to your table: There is probably an option checked in the Edit Relationship dialog for "Delete related records in this table when a record is deleted in the other table." It's probably on a cartesian-join relationship.

Link to comment
Share on other sites

That was it.

It was a relationship from way... way back. A relationship anchor that just carried along as this thing got worked on.

Thanks for pointing that one out. The core of this database has existed since Filemaker Plus.... you know... when the Mac Plus came out and it was put out by Nashoba Systems! I had this horrible fear that after all the upgrades and adding features, some ancient evil had done something horrible to my file!

Strange that it did not act up till now.

Thanks Again,

R

Link to comment
Share on other sites

This topic is 5720 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.