Jump to content

Import worked in FM 6 not in 8


Digital Life
 Share

This topic is 5639 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have a FM database that I converted from FM 6 to 8. Part of the solution does an import of a text file. It worked fine in FM 6 but does not in FM 8. When I import the text file it says 3,075 records have been imported.

If I import the same file into the old FM 6 database it imports 4,810 records.

If I open the text file with Excel and ask it to treat the file as a comma delimited file it finds 4,810 rows.

If I compare the Excel spread sheet (4,810 rows) with the FM 8 import the records are fine up to record 2,184. It has a single " at the end of a field. All the text in the file after that gets put into the next field for the following 102 records. That record has a single " at the end of a field.

My guess is that this is happening several times throughout the file reducing the number of records each time.

So my questions are:

1. What has changed in the import routine between FM6 and FM8?

2. Is there a way to change the import options in FM8 so as to get the same result as I used to get in FM6?

I tried importing the file into the FM8 database using comma delimited as an option of the type of file but I get reduced records every time.

Link to comment
Share on other sites

  • Newbies

Funny you should have a problem with importing - just what I was going to post a question about. My client solution in FM 6 imports a CSV file to update records. Normally under FM6 this takes about 20 - 30 secs for a 1MB file, whilst the converted solution in FM8 takes over an hour. I've found that if I change the indexing of the matching field from 'All' to 'Minimal' and turn off the 'Perform Auto Enter Options' its back to about 20 - 30 secs. This seems very odd. I'm running version 8.02 under Windows XP. Following the suggestion of the first person to reply to this query I coverted the CSV file to Excel, turned back on the 'All' option for indexing the matching field and the 'Peform Auto Enter Options' and tried importing the Excel file - worked a treat - back to 20 -30 secs. Still, its a pain having to change the method. Is this of any use to you and does anyone have an idea whats changed under version 8?

Link to comment
Share on other sites

This topic is 5639 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.