Jump to content

help please! works on pc, not on mac...why?


groovyds
 Share

This topic is 5663 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

Hi, I am updating a Filemaker Pro database file version 5 i think (.fp5)

I was working at the office on a mac in filemaker pro version 6v.4 to make changes to the current database. The program(database) is a label system which you enter some data in some text boxes, and then you select from a list of buttons on the side to decide what type of label you want the data to go on which type of label. i.e. a cd label, a dat label, a cassette label, etc. It works pretty well, (when it works). My job was to add a new style of label sheet to the list of labels. So that consisted of measuring out the different dimensions of the individual labels on the 8 1/2" x 11" sheet of label paper which we feed into the printer, and then laying out in filemaker pro the dimensions of the new label layout. Then creating another page which was something like a graphic type of page which had the same dimensions of the label page , but just had solid boxes over the individual labels with button links, in order to select which individual labels (if not in multiple mode, which would print out all of the labels on the page in one shot) you wanted to select to print. A simple script that was written before i got my hands on the program, from the guy who designed the original database program. So now the dillema, I created all the layouts, and made all the scripts work as i was supposed to, pretty much just copying previous scripts, and it was working as i was dooing it. For example there were 4 labels on the page, so i had to make 4 scripts to print for 4 individual pages (a different layout for each page , a different location of the label on each page), and when i tested it, it worked, even on the mac. great! now when i looked up the Multiple script from a previous one he had in the database , i wrote it down on some paper, exactly (i double checked) and when i created the print script for that multiple print page which pretty much is just a link to print the page which has all of the label on one page layed out all together on a page called something like DATPAGEALL that worked, cool i though i was in the clear...then things started acting screwy...i recall having to switch some names around in some scripts because some references were not right, but i fixed them to be proper, and linked to the right locaation and the right names...but things stoped working after that. my individual pages, were not printing properly, they linked to the proper pages, i.e. i saw a quick preview on the screen for a second then it vanished, but when i did a test print, i got a blank screen and some thing like it saying in the preview window preview of "size.pdf" ? dont know what that means.

this started happening to all 4 of my individuals and also to my multiple page when it came to previewing and printing. So get this..I have Filemaker pro 6 v.4 for the PC at home and i brought the file home with me from work to see what i can do to fix it, and i opened it up, and guess what ..i works fine....all the links and previews and printing is perfect. whats the deal??? how can i fix this so it works like this on my mac at work....i am running os10 at work. would it matter even if its os9? please help!!! and no i cant upgrade to version 8, they have this version (6v.4 at work and i have to stay with that version , at least for now)

thank you.

Link to comment
Share on other sites

is you have print script step set to no dialogue you may have accidently set it to print as pdf

(if you resave a script with print in it it stores your current print settings as default).

Printing in Mac & PC is different and there is usually a print script step for mac and one for pc... as pcs do not have print as pdf this would explain the difference

I usually just show the print dialogue window...

hope this helps.

If its not that (your reference to a blank window its probably a screwed up relationship with a go to related records script step).

stuart

Link to comment
Share on other sites

This topic is 5663 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.