Jump to content

SOAP with Troi URL Plug-in


jasonwood
 Share

This topic is 5578 days old. Please don't post here. Open a new topic instead.

Recommended Posts

G'day!

I'm trying to build credit card processing into my database.

I'm starting out with the bank's testing environment and I'm using the demo file included with the Plug-in. I've entered the URL: https://secure2.e-xact.com/vplug-in/transaction/rpc-enc/service.asmx

I've selected "POST" and put the following in the "Extra data to send" field...

POST /vplug-in/transaction/rpc-enc/service.asmx HTTP/1.1 

Host: secure2.e-xact.com 

Content-Type: text/xml; charset="utf-8" 

Content-Length: 2813

SOAPAction: "http://secure2.e-xact.com/vplug-in/transaction/rpc-enc/SendAndCommit" 

<?xml version="1.0" encoding="utf-8"?> 



xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 

xmlns:xsd="http://www.w3.org/2001/XMLSchema" 

xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/" 

xmlns:tns="http://secure2.e-xact.com/vplug-in/transaction/rpc-enc/" 

xmlns:types="http://secure2.e-xact.com/vplug-in/transaction/rpc-enc/encodedTypes" 

xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"> 

  

    > 

      

        A00990-01

        cadsmwp

        00

        250.00

        

       4111111111111111

        

        

        

        

        

        0808

        Mister Montfort

        

        

        

        

        

        

        

        

        

        

        

        

        

        

        66

        666

        6666

        en

        

        

        

      

   

I unchecked the "Use Content-Type..." checkbox, and I've tried with and without "NotEncoded" checked (actually I've tried checking and unchecking all sorts of things!)

I'm getting back $$500, or "500 Internal Server Error"

Anybody know what could cause an error 500? Could it be a minor error as simple as getting the Content-Length number wrong??

Link to comment
Share on other sites

  • 3 weeks later...

Thanks Martin,

That helps a little. The first two lines are easy, they're passed elsewhere in the plug-in, so I can forget about those. The next three lines can be set as a custom header using the "setcustomheader" function of the plug-in.

Still, I only get error 500 back. In fact even a blank message posted to https://secure2.e-xact.com/vplug-in/transaction/rpc-enc/service.asmx gives me 500 back. Only if I change the method to "Get" can I get anything other than 500.

Does this seem right? I mean, I can't imagine there's something wrong with the server, otherwise someone else should have noticed by now, but I must wonder why I am not at least getting errors in the 400's, like "bad request" or "not acceptable".

There must only be so many client problems that could cause an "internal server error" (500).

Link to comment
Share on other sites

This topic is 5578 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.