Jump to content
Sign in to follow this  
TheLagosChap

Find bug? (with periods like "YY_MM")

Recommended Posts

Hi,

I'm experiencing a rather weird behavior which I can't explain so far, hopefully sombedy out there can help.

I have a text field containing "month periods", with the content formatted as YY_MM, like:

07_01 for January 2007

07_02 for February 2007

etc

I'm trying a very simple "Find" on that field with something like:

">07_05" to give me all periods after May 2007.

This returns 07_08, 07_09, 07_10 etc but NOT 07_06 or 07_07.

I've tried to:

- find with the condition >"07_05" (with quotes)

- recover the file

- optimise and compress the file

Nothing makes a difference.

Obviously, if I add a calculated field in that table with the same condition (>07_05) it correctly returns true (or 1) for values like 07_06 nd 07_07.

Other similar finds (like <07_06) return also some similarly wrong results.

I've even tried to create a new database document from scratch with only one table and one field like this, I get exactly the same wrong find results!!!

The same (apparently wrong) behavior happens on a local 8.5 Advanced and on 8.0 server (both on Mac OS X).

Either it's a bug or I'm really missing something big.

Any clue or confirmation of this bug will help me staying away from a mental institution.

:-)

Thx,

TheLagosChap.

Share this post


Link to post
Share on other sites

Difficult to explain - it has to do with the field being text and "07_##" being two separate words. Note that it only finds records where at least one of the words meets the condition on its own.

You could replace the underscore with a period, or - preferably - move to another method altogether.

Share this post


Link to post
Share on other sites

I think I understand what you mean.

"_" would be some kind of "operator" influencing the search result.

It's just weird/sad it's not in the popup list of symbols.

I'm going to use another way then.

But thanks a lot for the hint. You saved me from the mental institution :-)

Share this post


Link to post
Share on other sites

"_" would be some kind of "operator" influencing the search result.

No, not at all. It's a word delimiter. Filemaker, when searching for text, searches for individual words. If you were searching for >C, it would find "Adam Digby". OTOH, a period, when placed between two digits, is NOT a word delimiter.

Well, I said it was difficult to explain...

Edited by Guest

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.