Jump to content
Sign in to follow this  
stewwy

A couple questions? Help?

Recommended Posts

Hello everyone,

I have used filemaker for quite some time, basically for data entry, now I am creating my own data base for my own home business. Basically I have it set up like this:

Title field:

Rating field:

Locations field:

Notes field:

Data field:

Right now, I have 2 questions. I have set up web publishing, but when my partner tries to access it from another computer via the web, it asks for a login name & password? I never put that anywhere? I have no clue what that would be, does anyone know where i would find that?

The other question is, I would love to build a Label stamp for my data portion. Basically where I click the button in the data field, and a list of about 5 things would show up:

"Phone number:

email:

Company:

etc.... "

Is there is a stamp I could use to create that field?

Any help would be greatly appreciated since the person I called for my one free call was of zero help? He said he couldn't do it but could do it in his spare time for a consulting rate.... Anyhow, no big deal. But any help would be awesome!

Thanks.

Share this post


Link to post
Share on other sites

Hi Stewwy,

User Names and passwords are found under File > manage > Accounts and Privelages. If you have not added any users, the default username will be Admin with no password.

Share this post


Link to post
Share on other sites

Stewwy,

Wadrod is correct, the default user name and password is “Admin” with no password. If you'd like the page to automatically log you in with no prompt for authentication, do the following:

1. Go to File > Manage > Accounts & Privileges...

2. Enable the Guest account.

3. Double click on the Guest account to bring up the properties. Click Edit... next to the Privilege Set. Verify that the "Access via Instant Web Publishing (fmiwp)” is checked.

4. Repeat step 3 for any other accounts listed, only for all accounts other then Guest, make sure the “Access via Instant Web Publishing” is NOT checked.

When the Guest account is the only account that has access via IWP it automatically logs you into the database with no authentication prompt.

As for your second question, what you could do for the data stamp is actually make the field title "Data field" a field its self.

I would suggest renaming the existing Data Field you created: "Data_Field_Data" (its generally a good idea to stay away from using spaces in field names) and then create a second field called “Data_Field_Title”. In the options for “Data_Field_Title”, under the Auto-Enter tab, check the Data option and specify “Data Field:” This will make it so the “Data Field:” title is what you’ll see by default.

Now create a value list ( File > Manage > Value Lists…). Name the value list something like Data Field Titles. We’re going to specify “Custom Values”:(

Phone number:

email:

Company:

To add the value list to title field, go into layout mode and double click on the field. Under control style, Display as: Drop-down List and then Display Values from: the value list we just created.

Now just resize and move the field to make it look like it’s the title for your data field.

Hopefully that answered your questions, if I miss understood what you were asking just let me know.

Share this post


Link to post
Share on other sites

Wadrod & fmpwnerer,

Thanks very much for the help.

Here is one thing I am encountering.... I was able to log in via the web. that was easy, thanks for the heads up there.. But when I created the database, I went to one of the templates and used "research notes". Then I just added fields. Now, I can type into the fields that I added no problem, but when I add a new one, there are only grey lines that represent the box for the original "research note" fields. Now that doesn't bother me, because it still has the labels for the other ones and I can still enter data for the other ones. But just now when did the value list, it entered those into "notes" which was originally there instead of my "data_field_data" field??

Did I not add these fields correctly in the very beginning? Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.