Jump to content

Basic XML request


Genx

This topic is 6160 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Hi Guys,

Kind of weird...

I can get this to return what its meant to (so all my xml settings are correct):

:)

http://***/fmi/xml/FMPXMLLAYOUT.xml?-db=Basic_Relational_One&-lay=People&-view




But this one keeps returning missing parameters (and i'm going off the fm examples)
http://***/fmi/xml/fmresultset.xml?–db=Basic_Relational_One&–lay=People&–findall

I can also get other basic calls to fmresultset.xml working like -view etc... just not the one directly above which returns a missing parameter error.

[color:blue]EDIT[ That was the case for the first few days i tried it, but now its working.. What could have been causing the error? ]

Any ideas are appreciated - Using FMSA 8.04.128

Also, is there anyway to pass the username and password of the account you want to use (i couldn't find that in the cwp doc). I mean i've set up guest access, but that's not necessarily what i want.

Thanks Guys!

Edited by Guest
Link to comment
Share on other sites

Hey Genx. Your syntax is perfect, so this really threw me for a loop. I have no idea how it happened, but each "-" in your argument names is not a normal dash. Instead of ASCII 0x2D, it is a unicode value 0x1320.

I just deleted the "-" and types in a new one in the browser. You have to do this for the "-db", "-lay" and "-findall" and then it starts working.

Did this URL get typed into Microsoft Word by any chance?

Geoff

Link to comment
Share on other sites

Ah, I'm fairly new to the whole using XML as XML side of FileMaker.

That being the case, I may actually have copied it from the FM CWP PDF, on to notepad, made various changes to the basic string and then tried the url - while this was a couple of weeks ago now and i can't really recall if i did the above, it sounds like something i might do. After that, i probably kept trying variations of the same copied and pasted string.

Its good to know that I won't randomly receive that error - I'm just happy there's some sort of explanation.

Cheers Geoff.

Link to comment
Share on other sites

This topic is 6160 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.