Jump to content

FMSA 9 & PHP Test Page Error


This topic is 6052 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I am wondering if anyone else has come across this problem. I've installed FMSA 9 having already had PHP 5.2.2 installed so set the installation to use the existing PHP installation. The PHP test.php page works fine when I open a web browser and type in:

http://localhost/test.php

However when I try to run the Test PHP Custom Web Publishing page all I get is a blank page.

The path to the phptest.php appears to be correct otherwise I would get a 404 error: page not found.

I have since updated to FMSA 9.0v2 which hasn't resolved the issue. Also I tried the Edit Server Deployment link which effectively reinstalls the web publishing engine which didn't work either.

I would be grateful if anyone can point me in the right direction on this.

Thanks in advance.

Link to comment
Share on other sites

Steven,

Thanks for your reply. Unfortunately this is not a multi-machine configuration it is a stand-alone setup.

I'm fast coming to the conclusion the only solution is to install the old version of PHP supplied with FMSA and that FMSA is not compatible with the later versions of PHP.

Does anyone else have FMSA running on an Intel Mac Pro using a later version of PHP than that supplied by FileMaker? If so, how was PHP installed?

Thanks again.

Link to comment
Share on other sites

Hi spacemonkey.

It sounds like I'm in the same boat as you. Our setup is a little different, and I arrived there differently, but the current problem is the same.

We have FMS9 running on Win2003 and FMS9A Web Engine and Apache running on OS X Server 10.4.11.

When we first upgraded to FMS9 and 9A, we chose to use the included version of PHP that came with the FM installation because we had been using PHP 4. We did install the v2 update. Everything worked, including the API pages.

When I discovered that the PHP 5.2.1 that came with FileMaker didn't include the GD library, I decided to install the latest copy of PHP 5.2.4 from entropy.ch which does include the GD library.

Everything else continued to work (IWP, FX.php, xslt) but the API pages quit working and now all we see is a blank page. When I view the page source, there are 2 lines of basic html stuff (DOCTYPE) but nothing else. The page dies where the PHP starts in the code. If I comment out the first set of PHP lines up to where the html tag begins, then the page displays just fine, but without any API functions.

I've followed the directions for installing the standalone version of the API (as best as I could) but that didn't help. I also tried running the Server Setup again in the Admin Console to choose the PHP that is provided by FileMaker, but that kills Apache every time.

So at this time we are stuck with 3 choices:

1) live without the API.

2) wipe the Apache server clean so we can get back to PHP 5.2.1 that comes with FileMaker, giving us the API but no GD library.

3) hope that someone has a solution to our problem.

Link to comment
Share on other sites

This topic is 6052 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.