Jump to content
Sign in to follow this  
CurlyD777

Date Search not working

Recommended Posts

Just today I ran into a problem searching a date field. In a invoice portal, that links records from an external filemaker table by account ID, I used to be able to search in that portal for a date range.

In other words, I could search for all invoices older than 60 days by just entering a date range. Recently, I cannot find invoices older than a month. I can search and pull up invoices within 2 weeks, but any date greater than that , it returns no records. I even manually looked for a record that had related records with a specific date from 60 days ago, it's listed in the portal, and when I searched for that specific date, it came back with no found records.

In the actual table, I can search and find these same records.

Anyone have any ideas why the portal search is not working anymore? I'm using server 9 advanced on a mac OS server 10.5.

Share this post


Link to post
Share on other sites

I would suggest that you search in the child table, anyway and then gtrr parents.

However, to answer your question, do you have filters on the portal relationship?

Share this post


Link to post
Share on other sites

Well, here's the bigger issue. We recently moved our files off of an older server onto a newer server, and, the new server is running FileMaker Server 9 on intel 64 bit xServe, vs Server 8 on the old intel iMac.

This is what I've found to both cause and fix the issue...and maybe someone can shed some light if they've seen this before.

In the portal, I'm relating invoices to accounts using a numeric account ID. In the invoice table, I also have a boolean "quote" field, allowing you to create quotes in the same table, but not have them show up in this particular portal.

These quotes are omitted by a match criteria rule that invoice's record's quote boolean field ≠ the global "1" field in the account's table. In other words, if the quote field is 1, it's not shown, and it is' 0 or blank, it is shown.

Up until 2 weeks ago, the boolean field didn't exist, so all of those previous records had an empty field. Blank fields in server 8w as not a problem as this allowed me to display and search those related records that had empty "quote" boolean fields

What I discovered in server 9, you can relate and display in a portal records with a blank match field using the ≠ symbol, but you can not search those records. So in other words, the portal was displaying the records, but not allowing me to search.

Whenever I develop boolean fields, I always set them auto enter 0 when a record is created, and go back and replace all records with a 0 if the database is already in use.

In this case, I forgot. Normally I would have noticed a problem earlier if the records weren't showing up in the portal, but what confused me was that I actually saw them listed, but I could not find pull up the same related records in a search.

Anyway, I replaced all the empty fields with 0's, and now it works flawlessly again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.