Jump to content
Sign in to follow this  

Problem wFMv10

Recommended Posts

I just tried ScriptMaster with FMv10 on XP. In FM Preferences I see that the plugin is loaded and in the Calculation Editor I see all the functions. However when running the auto-update script it generates an error, and looking at SMVersion in the Data Viewer I get the question mark.

Any one running ScriptMaster in v10?

Did I miss a notice about incompatibility?



Hmmm plot thickens! I just tried the same database in v9, which had been working with ScriptMaster, and I get the same behavior.

Any ideas why -

Could it be a java version issue?

Latest windows update issue?

FMv10 install issue?


One more thing - now tried testing some of the default function directly from the ScriptMaster DB - getting question marks in the Text result box for functions I know were working before. Still get the question mark when viewing SMVersion from the Data Viewer as well.

Edited by Guest
more testing

Share this post

Link to post
Share on other sites


This is an issue with our plugins, that we are aware of and are working on fixing.

However, when FileMaker is restarted the new version of the plugin should be running, so the issue is that FileMaker is not able to enable our plugin when it gets it from AutoUpdate, but after restart of FM the new version of plugin launches fine.

Share this post

Link to post
Share on other sites

Thanks Valentin.

Unfortunately there seems to be more to it. Now I can't get the functions to work using the ScriptMaster database - in either FM9 or FM10.

Not sure if this is something I have done or not. All was working fine until I installed FM10, now ScriptMaster is not working in either version.

Any ideas?


Share this post

Link to post
Share on other sites

OK - I replaced the ScriptMaster plugin manually in both FM9 and FM10 and things are starting to work. Still have more testing to do, but it's looking hopeful!

One not nice ramification is that any scripts that I had used SM Functions in lost what function was set - I had a bunch of places to re-set. Usually when I use a plugin function, and I open the script on a system without the function or I have turned off the plugin in FM Prefs, I will see this but as soon as the plugin becomes availablke again the script 'remembers' the original settings. Not the end of the world by any means, just very inconvenient.

So the short of it seems to be that my plugin became corrupted some way as just replacing it with a fresh copy is working.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  


Important Information

By using this site, you agree to our Terms of Use.