Jump to content

File Paths and Scheduled Scripts


bruceR
 Share

This topic is 4408 days old. Please don't post here. Open a new topic instead.

Recommended Posts

For files on FileMaker server, simple file references seem to work best and it seems that normally you do not need to take folders into account even if they are being used.

Except...

I have a client with about 40 files on their server and one of them is much larger than the others. So for backup schedule purposes it has been placed in a separate folder, and it is backed up less frequently.

MAIN

this.fp7

that.fp7

other.fp7

FOLDER2

bigfile.fp7

All file reference for files to each other are of the form:

file:this.fp7

file:that.fp7

file:other.fp7

file:bigfile.fp7

etc

Never noticed the slightest problem. All files and table occurrences pointing to external tables work flawlessly.

HOWEVER - tried to set up a new scheduled server script in this.fp7 that references data in bigfile.fp7

All the scripting activity is taking place in this.fp7 using table occurrences that reference the big table in bigfile.fp7

Everything works perfectly in script debugger and when running the scripts with FileMaker Pro.

But the scheduled scripts will NOT not work unless the bigfile reference is changed to:

file:bigfile.fp7

file:../FOLDER2/bigfile.fp7

FileMaker Server 10.0v2, MacOS Server (XServe) 10.6.5

Bruce Robertson

Link to comment
Share on other sites

I have a client with about 40 files on their server and one of them is much larger than the others. So for backup schedule purposes it has been placed in a separate folder, and it is backed up less frequently.

It is quite possible to exclude the one file from the regular backup process but still leave it in the same directory as the others. Just note the options for selecting files when creating a backup schedule.

Steven

Link to comment
Share on other sites

Thanks, I'm aware that that can be done. But I see that the same issue just came up on TechTalk. It is inconsistent behavior and should not be happening, and as far as I know is not documented.

Link to comment
Share on other sites

It *is* a problem. Quoting from Techtalk:

Good morning, Bruce!

Thank you, thank you, thank you ....

That did the trick;-)

/Heine

That's the problem. You will need to change your file references to reflect the folder structure; or go back to putting them all in one folder.

Just went through exactly this scenario myself and posted about it a few days ago.

Bruce Robertson

Concise Design

Link to comment
Share on other sites

This topic is 4408 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.