Jump to content

Problem in importing date from Excel into FileMaker


supernatural
 Share

This topic is 4369 days old. Please don't post here. Open a new topic instead.

Recommended Posts

I have an Excel with a number of date fields and text fields.

When I drag and drop Excel spreadsheets to instantly import into FileMaker Pro, the date field in Excel becomes text field in FileMaker. When I changed it to date field, all the dates become 'garbage'

I have to save my Excel into .csv first before doing the import. Is this the only way ?

Link to comment
Share on other sites

If the date is still recognizable as such after you import, with the only problem being that FileMaker thinks it is text, then it might help if you use Replace Field Contents to replace the field with the calculation GetAsDate ( [fieldname] ) before converting the field type to Date.

If you do a manual import into an existing file, rather than drag and drop, you could set the above GetAsDate function as an auto-enter calculation for the date field, and check the "Perform auto-enter options" box on import.

Edit: Also, you might want to check the date formatting in the Excel file, because when I dragged and dropped a sample Excel file onto FileMaker, the field with dates entered into it shows up as a Date field in Manage Database, no conversion necessary.

Link to comment
Share on other sites

This topic is 4369 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.