Jump to content

Moving Supercontainer to a new server


 Share

This topic is 4310 days old. Please don't post here. Open a new topic instead.

Recommended Posts

Several months ago I purchased supercontainer. I then loaded supercontainer to my server and implemented it in a solution for an art gallery. They have since decided to go with their own server and so several weeks ago I installed supercontainer on their server and took it off mine. A quick call to 360 works seemed to give me enough information to move the directories and files to the new server. I installed supercontainer and Inside the LAN I can see the images as I changed the supercontainer link to that of the internal IP address of their new server. However, I can not see it remotely. I assume I should be using the external (port forwarded) address but when I do that I can't see the files Locally. What have I done wrong?

Link to comment
Share on other sites

Sometimes routers don't like it when you use their external IP address internally. If you are able to see the documents from outside your office using the external IP address, but not from within the office when using the same address then this may be the case for you.

If this is happening you will need to modify your calculations to check and see where your users are connecting from, and if you should use an internal or external ip address. FileMaker has the get(hostIPAddress) function which you can use in situations like this. If this function returns your internal address you should set your web viewers/scsetbaseurl to use your internal address. If it is the external address you will know to use the external address. This can be configured in your scripts and calculations by using the IF script step and the Case calculation function.

Link to comment
Share on other sites

Sometimes routers don't like it when you use their external IP address internally. If you are able to see the documents from outside your office using the external IP address, but not from within the office when using the same address then this may be the case for you.

If this is happening you will need to modify your calculations to check and see where your users are connecting from, and if you should use an internal or external ip address. FileMaker has the get(hostIPAddress) function which you can use in situations like this. If this function returns your internal address you should set your web viewers/scsetbaseurl to use your internal address. If it is the external address you will know to use the external address. This can be configured in your scripts and calculations by using the IF script step and the Case calculation function.

David

Thanks for your response!

I tried the following in my "On Open" script that sets the base URL (IP addresses are not real)

If(Left ( Get ( HostIPAddress ) ; 2 ) = "63";SCSetBaseURL("http://63.456.80.63:80/SuperContainer/Files");SCSetBaseURL("http://192.168.0.254:80/SuperContainer/Files"))

This does not appear to work as it returns "error". I beleive part of my problem is that setting the base URL is part of the registration and could be locked down to the original server IP address.

Ideas?

Link to comment
Share on other sites

You should not specify port 80, as that is the default port. You can call SCLastError to see the details about the last error that you received.

SCSetBaseURL is not tied to a particular server, so there should be no problem changing the IP address. SCLastError will tell you what the problem is.

Link to comment
Share on other sites

David

Here is my current script step

If(Left ( Get ( HostIPAddress ) ; 2 ) = "63";SCSetBaseURL("http://63.231.80.63/SuperContainer/Files");SCSetBaseURL("http://192.168.0.254/SuperContainer/Files"))

Here is the error that is returned.

Unable to connect to http://63.231.80.63/SuperContainer/Files. Verify that the port number is correct. For standalone usage, the default port is 8020. For tomcat deployment, the default port is 80.

... not sure what this means. I am using the server plugin... Does it suggest that I should open port 8020 on the router?

As always thanks!

Link to comment
Share on other sites

If you try http://63.231.80.63/SuperContainer/in your browser you will notice that it does not work. There is something blocking port 80 right now (which you appear to be using) and so your users are unable to connect to it. You will need to open port 80 in your firewall or forward port 80 in your router.

Link to comment
Share on other sites

This topic is 4310 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.