Jump to content
Sign in to follow this  
tomp

selecting objects on a layout

Recommended Posts

Pre-FM12, groups of objects on a layout were selected by encircling them. If they weren't completely within the circle they weren't selected. In FM12, any object touched is selected.

Is there a 'preference' in FM12 to use the old means of selecting objects on a layout? Or am I stuck with the new way which is a real pain when editing complex layouts?

Share this post


Link to post
Share on other sites

FileMaker only switch how this works from previous versions.

FMP11 and previous versions, you could select what you touch by using the Command Key.

FMP 12, it is just the reverse.

Lee

  • Like 1

Share this post


Link to post
Share on other sites

Thanks! That helps alot.

Share this post


Link to post
Share on other sites

Sorry Lee. I cannot seem to make this work with any key combination. In other words the only way to select an object surrounded by another object is to tab (tons of times) to it. It is quite frustrating. I am working on a mac using FMP12 Advanced.

Share this post


Link to post
Share on other sites

You are referring to the "Layout Mode" correct?

Share this post


Link to post
Share on other sites

Why are you tabbing?

 

Hold down the Command Key, and with your cursor, touch those things that you want to select; Let me know if it doesn't work. You will need to hold down the Shift Key too.

Share this post


Link to post
Share on other sites

I have tried every key combo that I can think of include Shift+CMD and just CMD. But when I do the selection on anytime inside the bounding box it ALWAYS selects the bounding box and will not let me select anything inside of it. This happens on most layouts. I can attach a file with a dummy layout if you like. Don't know how to attach a file to a reply though.

Share this post


Link to post
Share on other sites

:doah:

In v12, ir only looks like you have selected everything. The box is not really showing what you think it is.

 

 

try this. Select a couple of fields, and drag them to the right. You should notice that the labels stay in place.

Share this post


Link to post
Share on other sites

Lee I appreciate your help with this, however I can not select the fields. That is the problem. Is there a way I could send you a stripped down fmp file (319KB) to show you the issue?

Share this post


Link to post
Share on other sites

attach it here.

 

Find the file on your hard drive, and zip it.
Do not use the Quick Reply, BUT instead, choose the More Reply Option 
Click on Attached Files and this will take you to your hard drive to locate your file that you want to attach and that you previously zipped. Select the file, and then click Attach This File, and then click Add Reply.

Share this post


Link to post
Share on other sites

Ah. selection.fmp12 is attached. I just copied the layout from my solution into a new fmp file. The interaction in layout mode work exactly the same. Just try to select any field inside the red boxes.

 

Thanks

David

Share this post


Link to post
Share on other sites

It appears that you were unsuccessful with attaching your file. Please be sure that you have followed the steps above.`

 

You should see this on the More Reply Options

post-55421-0-11155500-1358287603_thumb.p

Share this post


Link to post
Share on other sites

Sorry Lee. Probably did not hit the Attach button after I choose the file. Hopefully this one worked.

selection.fmp12.zip

Share this post


Link to post
Share on other sites

I think it has to do with the order of the objects. i.e. the red box is on top and is blocking your ability to select what's behind it.

 

Try sending it to behind and see what happens.

Share this post


Link to post
Share on other sites

That seems to work. So in order to select a field in fmp12 I have to constantly rearrange the objects in my layout...seem kinda strange no? I can think of no advantage to have the layout function in this way. Are other people having problems working in layout mode?

Share this post


Link to post
Share on other sites
That seems to work. So in order to select a field in fmp12 I have to constantly rearrange the objects in my layout...seem kinda strange no? 

 

No, because these things haven't changed. IMO, the addition of the new alignment frames made it easier.

 

The stacking order of the Layout Objects has been around since before I started developing in v3 20 years ago. The Arrange tools are your friends and it is important to understand how they work.

 

You might want to review the help about the using the Arrange tools Selecting objects

Share this post


Link to post
Share on other sites

Lee thanks for your assistance, but I have to disagree. I opened an older version of this file in fmp11 and I can select any field without issue, even with the outline box (on the top layer) surrounding the field I am selecting. I have been working with layout in fmp for many years and this has never been an issue, only with fmp12. 

Share this post


Link to post
Share on other sites

Apparently we have a difference of opinion on how this is working.  I really don't have a problem with it. In fact, you are the first person that I know of that has commented on it.

 

I would love to see what the others feel about this. Hello LaRetta!

 

Not sure if this is different on other platforms, using different operating systems (Mountain Lion v Snow Leopard)

I'm using the latest version of FMP 12.0.3 

 

Lee

Share this post


Link to post
Share on other sites

Lee I did a quick screen recording to show you how this is working on my computer just to make sure we are talking about the same thing.

ISUHD15.mov.zip

Share this post


Link to post
Share on other sites

Thanks for posting your video. I think it represents exactly what I understood as your problem.

 

IMO, this is a bug and should be reported to FileMake, have you done this?  (see my next post)

 

I feel that it's  probably related to the change they made to buttons.

 

Can you attach the version 11 file?

Share this post


Link to post
Share on other sites

Update:

 

I went to FileMaker's Known issues Here and did a search for stacking order and see that this has been reported. Why don't you join in the report, and also point to your video here?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.