Jump to content
Sign in to follow this  
hedata

IIS and FileMaker Server

Recommended Posts

Hi everyone,

I've transferred across a database to my FileMaker Server which was previous being hosted by another company. Most users connecting via a custom php IWP login page uisng a sub-domain of my site. However some users, including me when I use my office PC, type in that URL and still get the old login page from when it was hosted with the other company. They simply cannot load the new database as its moved location. I have successfully changed the DNS settings on the subdomain and have contacted my hosting company (1&1) to verify this.

To access the custom IWP login page I’ve tried:

  • Flushing my office PC’s DNS (cmd > ipconfig /flushdns)
  • Deleting web browser cache and cookies
  • Trying a different web browser

When doing this on my office PC this still brings up the old login page. When I access at home or on my database server the new IWP login page works! Bizarrely several people have connected successfully through the new IWP login page, whereas others simply cannot get to it using the same URL.

I was wondering whether this is an issue with IIS? The server is hosted using Windows 7 Professional (IIS 7.5). Is it somehow remembering the IP’s of people who have used the database in the past? Is there a DNS issue somewhere? The one thing I haven’t done is rebooted the server or flushed the DNS on it, I wonder if either of those tricks are worth doing?

I’m absolutely stumped. If you could provide me with some pointers I’d be really grateful!

Share this post


Link to post
Share on other sites

How long has it been since you changed the DNS on your subdomain? Do you know what the TTL setting was/is for that DNS record? This sounds to me like a classic case of the DNS record being not fully propagated, which means you just need to wait longer and it will fix itself. In the meantime, you could use use the IP address to access the database.

http://en.wikipedia.org/wiki/DNS_propagation#Record_caching

Share this post


Link to post
Share on other sites

Hi Dan,

Thanks for your help. I'm pretty sure it was a DNS A-Record issue, it does seem to have resolved itself over time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.