Jump to content
Sign in to follow this  
Nico Kobes

Error: Mirrorsync script out of date or missing script steps

Recommended Posts

Hi there !

I'm having some troubles setting up Mirror Sync.

Database setup steps 1-4 going well, but clicking on Finished get the message:

You will not be able to successfully sync. MirrorSync script is out of date or missing script steps. Would you like to save changes anyway?

Can you help me with this?

Mac OS 10.7.3 Client. (dutch language)

Filemaker Server 12.0v2

Share this post


Link to post
Share on other sites

Hello Nico,

We added support for the Dutch version of FIleMaker in 1.26. Please make sure you have downloaded the most recent version of MirrorSync.

Could you open the MirrorSync script in the server version of the file and let me know what it looks like? Just a screenshot of the first few lines might help diagnose the problem.

Thank you,

Sarah

Share this post


Link to post
Share on other sites

Hello Sarah,

Thanks for helping me :)

The version of MirrorSync is: MirrorSync 1.261, build 5452

I'm uploading 2 screenshots, maybe this will help..

In the Database setup is a triangle error with the message.

Thanks,

Nico

post-101709-0-66722000-1346077773_thumb.

post-101709-0-20852100-1346077790_thumb.

Share this post


Link to post
Share on other sites

Hi Nico,

Thank you for the screenshots! I think we've found the issue with the triangle error. Please download this file and try to install this new version of MirrorSync, it should solve the problem.

https://rcpt.yousendit.com/1681178125/f356b5b716b7b6a927b42bd8a93cf4bd

Thanks again,

Sarah

Share this post


Link to post
Share on other sites

Thanks Sarah,

I just installed the update, sorry but the same error still exists.

Is there something else i should do except upgrading?

Share this post


Link to post
Share on other sites

Hi Nico,

No, that should have worked. Can you please send me your MirrorSync server log file? On Mac, this is located at /Library/FileMaker Server/Logs/360Plugin Logs. On Windows, it is located at C:Program FilesFileMakerFileMaker ServerLogs360Plugin Logs.

Thank you,

Sarah

Share this post


Link to post
Share on other sites

Thank you.

Nico, it looks like the Dutch version of the web publishing engine produces slightly different date and time formatting outputs. If it all possible, could you perhaps set up a test account where I could access your XML publishing engine? This would help me sort out why I'm getting a different result than I expected.

You can email me at sarah@360works.com

Thank you!

Sarah

Share this post


Link to post
Share on other sites

Alternatively, try going to this URL:

localhost/fmi/xml/FMPXMLRESULT.xml?-db=Gebied_Rijpelberg&-lay=Sync_Gebied_Rijpelberg&-findany

And replace localhost with the name of your server. Please let me know what shows up in the browser.

Thank you!

Sarah

Share this post


Link to post
Share on other sites

Hi Sarah,

I have send you a private message with the XML output.

I will setup a test account and send you a email.

Share this post


Link to post
Share on other sites

I am having the same problem maybe its related to the language I had spanish, but turn into english and the problem remains I am trying with a really simple table, just 4 fields (PK, name, price and modification) every thing have been done at least 4 times in spanish and in english (FMP Adv 11v4) and always the red triangle remains with the same text that started this thread. Any help is welcomed 

Share this post


Link to post
Share on other sites

Fellas,

The problem here is not the language, but the region. The number, time, and date formats are to blame. What's probably happening is your computer (and filemaker if it is inheriting locale settings from the system) are using number formats that differ from your Java installation's number formats. So when we try to set a variable to 1.4306, FileMaker comments this out because it should have been set to 1,4306. In the newer, unreleased build, this issue is fixed, and a new release will be rolled out soon, but for now, the easiest way to fix this is to edit the script right after pasting it. Look at the very beginning of the script for the step: "Set Variable[$mirrorSyncVersion ; Value:/*1.4306*/] and change the value to either 1,4306 or "1.4306" in quotation marks. Either change will suffice.

 

Hopefully that will resolve the client info NullPointerException problem you guys are experiencing.

 

Cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.