Jump to content

Beach ball during EmailConnectSMTP()


Kyle Putzier
 Share

This topic is 2591 days old. Please don't post here. Open a new topic instead.

Recommended Posts

  • Newbies

I have some users (maybe all users, except me) that get a beach ball during EmailConnectSMTP(). It appears to timeout after 10 seconds or so and then connects normally. My computer connects with no noticeable delay. I have checked login usernames and passwords and they are accurate. The users were able to quickly connect at one point in the past.

Immediately checking EmailLastError returns blank  ""

 

EmailConnectSMTP( 
"smtp.gmail.com:465" ; 
_MiscTable::User_EmailAddress; 
_MiscTable::User_EmailPassword;
"ssl=1";
"tls=T" ;
"forceTrust=true";
"timeout=5" 
 )
 
Tried adding these args with no effect:
port 465
"forceTrust=true";
"timeout=5" 
 
I have also substituted my login credentials and the users delay remains. Leads me to believe it is something else, but what?
 
 

 

all computers OS X 10.9.X

database served via FMS

User computers FMP13 (firewall off)

My computer FMPA13

All on same network

 

Kyle

Link to comment
Share on other sites

  • Newbies

Have you tried disabling TLS in the google admin console? and in your app

TLS is in there because I didn't know what it was and that is the way 360 had their example. I use Google Apps for Business and a check of  the TLS setting shows that it is "not configured yet".

Either way, I removed TLS in EmailConnect and it had no effect.

 

Kyle

Link to comment
Share on other sites

have you looked into recent updates on the computers to see if they have something different than you do and or and you tried logging in as one of the users from a remote location to narrow it down to a network or Filemaker issue.

Link to comment
Share on other sites

  • Newbies

have you looked into recent updates on the computers to see if they have something different than you do and or and you tried logging in as one of the users from a remote location to narrow it down to a network or Filemaker issue.

 

I chose one particular users computer and was determined to find a difference.

Check OS version, check FMP version, checked plugging version, check security/firewall settings, checked it's ping and networks speeds. Everything seems normal.

Hang on, I did not check the DNS

 

... time passes ...

 

My computer was using Google free dns (8.8.8.8)

There users are set to the router default (AT&T ?)

If I set the users to 8.8.8.8, connections are fast. Back to router default, connections are again slow.

I change the router to use 8.8.8.8 and the user connection are still slow if they are set to the router default.

 

This leads me to believe we have a in-house dns issue. It doesn't seem to affect anything except the EmailConnect function.

My temp solution is to set the users to get their dns directly from Google (8.8.8.8)

 

Kyle

Link to comment
Share on other sites

This topic is 2591 days old. Please don't post here. Open a new topic instead.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.